Weird problem with invalid sprites on GRFs

Got a problem with TTDPatch? Get help here.

Moderator: TTDPatch Moderators

Post Reply
User avatar
Andrex
Tycoon
Tycoon
Posts: 1308
Joined: 22 Nov 2002 05:08
Contact:

Weird problem with invalid sprites on GRFs

Post by Andrex » 02 Nov 2007 06:06

Hi,
I'm trying to make work an old game of mine, last saved on february of this year, and with latest beta versions I keep getting error regarding "invalid sprites" on certain GRF files that worked perfectly before... such as the cargo set, temperate set, and paper wagons. See attachment.

The errors disappear only when reverting to 2.0.1 alpha 73, and appear when using anything newer than it (2.5 beta 1 and so on)

Any solution or workaround for this will be appreciated.
Attachments
sprites.gif
sprites.gif (30.03 KiB) Viewed 3007 times
ttdpatch.zip
(2.01 KiB) Downloaded 62 times

DaleStan
TTDPatch Developer
TTDPatch Developer
Posts: 10285
Joined: 18 Feb 2004 03:06
Contact:

Re: Weird problem with invalid sprites on GRFs

Post by DaleStan » 02 Nov 2007 07:01

There's a FAQ about this.
To get a good answer, ask a Smart Question. Similarly, if you want a bug fixed, write a Useful Bug Report. No TTDPatch crashlog? Then follow directions.
Projects: NFORenum (download) | PlaneSet (Website) | grfcodec (download) | grfdebug.log parser

User avatar
Andrex
Tycoon
Tycoon
Posts: 1308
Joined: 22 Nov 2002 05:08
Contact:

Re: Weird problem with invalid sprites on GRFs

Post by Andrex » 03 Nov 2007 06:25

The solution there is to "use a more recent version", which are incompatible with these GRFs.

If creating new GRF features for TTDPatch introduces such backwards incompatibility that leaves old GRF sets instantly obsolete, well, I completely disagree with this... I'll have to stick to a stone-age version to play my games. I assume future versions will require Windows Vista to run, if this same compatibility policy is used. I think old GRF sets should still be compatible because many of them are great work done by lots of people that deserve some kind of respect, regardless of being discontinued or not.

Uwe
Transport Coordinator
Transport Coordinator
Posts: 353
Joined: 09 Jul 2004 14:05
Location: Germany

Re: Weird problem with invalid sprites on GRFs

Post by Uwe » 03 Nov 2007 07:17

You did not read the second paragraph in the FAQ, did you?

"If the message mentions "code 24", this means you have accidentally turned on the "mandatory GRM" feature. Try putting "experimentalfeatures.mandatorygrm off" in your ttdpatch.cfg file."

This works with any recent Patch version.

DaleStan
TTDPatch Developer
TTDPatch Developer
Posts: 10285
Joined: 18 Feb 2004 03:06
Contact:

Re: Weird problem with invalid sprites on GRFs

Post by DaleStan » 03 Nov 2007 08:24

That, of course, does not work by copy-and-paste into TTDXC. But I've told you this umpteen times before, so I don't see why you'd be any more likely to listen this time.

/me edits the wiki to mention this little detail, indirectly.
To get a good answer, ask a Smart Question. Similarly, if you want a bug fixed, write a Useful Bug Report. No TTDPatch crashlog? Then follow directions.
Projects: NFORenum (download) | PlaneSet (Website) | grfcodec (download) | grfdebug.log parser

User avatar
Andrex
Tycoon
Tycoon
Posts: 1308
Joined: 22 Nov 2002 05:08
Contact:

Re: Weird problem with invalid sprites on GRFs

Post by Andrex » 04 Nov 2007 01:48

DaleStan wrote:That, of course, does not work by copy-and-paste into TTDXC. But I've told you this umpteen times before, so I don't see why you'd be any more likely to listen this time.
Copy paste..? I simply turned off the third switch on the Experminetalfeatures bitswitch with TTDXC, and problem fixed.

Thanks!

DaleStan
TTDPatch Developer
TTDPatch Developer
Posts: 10285
Joined: 18 Feb 2004 03:06
Contact:

Re: Weird problem with invalid sprites on GRFs

Post by DaleStan » 04 Nov 2007 03:42

I'm not quite sure how you could have made my point more beautifully.
To get a good answer, ask a Smart Question. Similarly, if you want a bug fixed, write a Useful Bug Report. No TTDPatch crashlog? Then follow directions.
Projects: NFORenum (download) | PlaneSet (Website) | grfcodec (download) | grfdebug.log parser

User avatar
PaulC
Director
Director
Posts: 616
Joined: 31 Jul 2006 12:40
Location: Lancs, England
Contact:

Re: Weird problem with invalid sprites on GRFs

Post by PaulC » 04 Nov 2007 14:18

o/t...

What's the "Small Airport, Modern Style" grf that you're using?
Attachments
sprites.gif
sprites.gif (30.03 KiB) Viewed 2734 times

User avatar
Andrex
Tycoon
Tycoon
Posts: 1308
Joined: 22 Nov 2002 05:08
Contact:

Re: Weird problem with invalid sprites on GRFs

Post by Andrex » 04 Nov 2007 18:08

Well it's this exactly...
Attachments
sma.gif
sma.gif (29.57 KiB) Viewed 2695 times

User avatar
PaulC
Director
Director
Posts: 616
Joined: 31 Jul 2006 12:40
Location: Lancs, England
Contact:

Re: Weird problem with invalid sprites on GRFs

Post by PaulC » 04 Nov 2007 19:05

Is it available for download by any chance?

User avatar
Andrex
Tycoon
Tycoon
Posts: 1308
Joined: 22 Nov 2002 05:08
Contact:

Re: Weird problem with invalid sprites on GRFs

Post by Andrex » 05 Nov 2007 03:59

Here.
Attachments
smallairport_190.grf
(8.48 KiB) Downloaded 153 times

User avatar
PaulC
Director
Director
Posts: 616
Joined: 31 Jul 2006 12:40
Location: Lancs, England
Contact:

Re: Weird problem with invalid sprites on GRFs

Post by PaulC » 05 Nov 2007 04:07

Awesome. Many thanks! :)

Post Reply

Return to “Problems with TTDPatch”

Who is online

Users browsing this forum: No registered users and 1 guest