Sudden graphics issue...

Got a problem with OpenTTD? Find some help here.

Moderator: OpenTTD Developers

Post Reply
kokutetsu
Engineer
Engineer
Posts: 28
Joined: 02 Dec 2018 05:50

Sudden graphics issue...

Post by kokutetsu » 02 Dec 2018 05:56

So I've been playing this game since 1914 without any issues, with all the Japanese add-ons, and now when I started the game up the graphics have gone all weird... see the attached image. Before this, it's all been working beautifully. I tried starting a new game too, but it's giving me the same issues with the graphics... any ideas? Thanks!
Attachments
ottd.png
(517.79 KiB) Not downloaded yet

User avatar
kamnet
Moderator
Moderator
Posts: 6892
Joined: 28 Sep 2009 17:15
Location: Eastern KY
Contact:

Re: Sudden graphics issue...

Post by kamnet » 02 Dec 2018 06:13

You've accidentally enabled transparency mode for buildings. You can disable it by opening the Transparency Option toolbar from the Options button (gear icon), or press Ctrl+4.

kokutetsu
Engineer
Engineer
Posts: 28
Joined: 02 Dec 2018 05:50

Re: Sudden graphics issue...

Post by kokutetsu » 02 Dec 2018 06:36

That was the first thing I tried, because I use the transparency option often when working on urban transport... but if you look at the screenshot, there should be station platforms visible next to the factory, and the trees are also transparent... which is the entirely new situation I've not seen before that's come up suddenly.

Here's another screenshot, with a town visible...
Attachments
ottd2.png
(551.78 KiB) Not downloaded yet

User avatar
kamnet
Moderator
Moderator
Posts: 6892
Joined: 28 Sep 2009 17:15
Location: Eastern KY
Contact:

Re: Sudden graphics issue...

Post by kamnet » 02 Dec 2018 06:40

Yes, each of those have individual transparency settings. Ctrl+1-9 will toggle each of them. In addition, the Transparency Options menu bar has a second button under each setting to toggle between transparent (the shadow-y, grayed-out look) and invisible.
Attachments
transparency.png
(972.44 KiB) Not downloaded yet
Last edited by kamnet on 02 Dec 2018 06:59, edited 1 time in total.

kokutetsu
Engineer
Engineer
Posts: 28
Joined: 02 Dec 2018 05:50

Re: Sudden graphics issue...

Post by kokutetsu » 02 Dec 2018 06:43

Oh there we go, thank you! :)

Eddi
Tycoon
Tycoon
Posts: 7424
Joined: 17 Jan 2007 00:14

Re: Sudden graphics issue...

Post by Eddi » 02 Dec 2018 12:46

also mention the [X] key?
You might not exactly be interested in Ferion, but if you are, have fun :)

User avatar
NekoMaster
Tycoon
Tycoon
Posts: 3945
Joined: 16 Aug 2008 22:26
Skype: neko-master
Location: Oshawa, Ontario, CANADA

Re: Sudden graphics issue...

Post by NekoMaster » 02 Dec 2018 17:19

I always use the X key for toggling transparency
Image Proud Canadian Image
Nekomasters Projects! (Downloads available on BaNaNaS!) \(>^w^<)/
# NARS ADD-ON SET 2CC | 2cc Rapid Transit For Me! (2ccRTFM) | 2cc Wagons In NML (2ccWIN)
# NML Category System (Organize your GRFS!) <- TT-Forums Exclusive Download!

Post Reply

Return to “OpenTTD Problems”

Who is online

Users browsing this forum: No registered users and 5 guests