Page 1 of 1

[Stations] Animated color is different when MASK file is used

Posted: 09 Oct 2020 18:09
by Quast65
Hi all!

When I code a station with 32bpp graphics and use a MASK file to add an animated color, the color is different than the "regular" animated color when I code the same station with just 8bpp graphics:
Example550.png
Example550.png (41.14 KiB) Viewed 460 times
It's a lot lighter…

I think it has something to do with the color I use in the 32bpp graphic where the animated colors should be.
What color should I use in the 32bpp graphic to have no changes in the look of the animated color?

Re: [Stations] Animated color is different when MASK file is used

Posted: 10 Oct 2020 14:12
by Andrew350
I've found using a mid-range grey color, something like index 202 in the DOS palette for example, seems to produce good results, though I've never done a side-by-side comparison to see if it's exactly the same. You may have to adjust it a bit, just remember it's mostly the brightness which affects the result of masked colors, so mid-greys are usually a solid choice for a neutral result, but depends what you're looking to achieve :)

Re: [Stations] Animated color is different when MASK file is used

Posted: 10 Oct 2020 16:36
by Quast65
Andrew350 wrote: ↑10 Oct 2020 14:12 I've found using a mid-range grey color, something like index 202 in the DOS palette for example, seems to produce good results,
Cheers mate!
For me, this one made the colors look close enough to the original:
MASK_UnderlayColor.png
MASK_UnderlayColor.png (335 Bytes) Viewed 393 times
(For future reference)