A Resource for problems with Locomotion....please read.

Got problems with Locomotion? Find assistance here!

Moderator: Locomotion Moderators

Locked
User avatar
Greyfox
Transport Coordinator
Transport Coordinator
Posts: 371
Joined: 19 Jun 2009 14:47
Location: Victoria, Australia

A Resource for problems with Locomotion....please read.

Post by Greyfox » 31 Aug 2014 08:03

This topic refers to computers that are running Windows XP and Windows 7.

After looking through the topics on Locomotion, it seems to me that over the last few weeks/months a number of members on the forums have had problems with Locomotion, such as: “unable to initialise graphics system”, “Lomo won’t start”, “rainbow colours”, etc, etc, the same old questions over and over again, annoying both moderators and members alike. So I thought I should submit a topic about it and offer some possible solutions to these annoying problems. Also offer a source of reference to members who have these problems, both new and old.

Firstly, I should state that the possible answers to these problems are based upon my own experiences, and seeking answers on the forums and internet, (of which there are many opinions on this subject). Up until a few months ago, I used Windows XP SP2, then upgraded to Windows 7 Home Edition. I rarely had a problem with XP, but with Win 7, that was a different matter. So I submit some possible solutions to these problems.

Unable to start Locomotion:

Unfortunately, the first point that comes to mind, “is the member using a legal copy of Locomotion”? Any use of pirated software on these forums is very heavily frowned upon. So don’t expect any help here. You may incur the wrath of a moderator.

However, this is not always the case. The problem could be: a faulty disc, corrupted file(s) etc. If the game is from a legal download, try downloading and reinstalling again. If the problem persists, then refer it back to the supplier. If you have a disc and the disc is faulty, then you may have no other option but to return it for exchange, or ask for your money back. (further solutions are shown below, that may be connected with this problem). Also, changing the ObjData folder to run other mods can cause the game to fail. If I change ObjData folders, I restart the computer first, then Locomotion. It usually works for me. You may have to remove a scenario from the ObjData folder that is conflicting. (this has happened to me).

Graphics, colour problems:

Any OS from Windows Vista onwards appear to have this problem with Locomotion. There are many answers to this, so I present the following possible solutions:

1). Try “compatability mode”. (right click Loco.exe, left click Properties, left click Compatability and try running in Windows XP mode, and/or run as administrator).

2). Change your desktop to “Classic mode”. When you are in a game, try different resolutions. In fact, you may have to change your desktop resolution. (my desktop is 1600 x 900, and ingame is 1280 x 768), works for me on a wide screen monitor.

3). Close any Windows apps. that you may have open, such as file browsers, internet browsers, or any apps. that you are not using. All of these use up your computer’s resources which you may need to run Locomotion. (CPU, GPU etc). Sometimes, just a simple game restart fixes the current problem, but it is not a cure. It will probably happen again.

4). Graphics cards: Because of the increasing amount of scenarios/maps and mods that are being created, Locomotion has become more computer resource dependent. I have always recommended that a graphics card should be used when playing Locomotion. I myself use an nVidia GT 610 2GB with no problems. It has served me well with Locomotion. I realise that those of you with high end computers are quite satisfied using the on board graphics.

5). There shouldn't be any need to change from 32bit to 16bit resolution. I run mine as a 32bit with no problems.

Summary:

If you follow the steps shown above, you will be well on the way to fixing your problem. If all else fails, and you have a graphics card, try updating your graphics drivers.
To those of you that have a pirated copy, get rid of it! There are plenty of opportunities to purchase a copy. Look in the “bargain bin” of your local retail outlet, or online outlets, such as eBay, GOG, Amazon, or such like.The game should be quite cheap. I bought mine years ago from eBay.com.au for $5.00AU, in perfect condition, with a manual. There was no marks on the CD, and there still isn’t. It works perfectly.

I hope that this topic helps those that are having problems like those shown above. Please use the tt-forums search function and/or an online search tool for further answers. Remember, it can take more than one (1) search criteria, or keywords, to find an answer. All to often it can test your patience.

Cheers and good luck!



Greyfox.
Windows 10 discussion here: http://www.tt-forums.net/viewtopic.php?f=2&t=72527
Looking for AMI trains, Chicago Locomotive Works, etc: You'll find your needs here: http://www.locomotiondepot.net/
__________________________
"Don't badger the Badger"....(Retired Moderator)

Locked

Return to “Locomotion Problems, FAQs and Tutorials”

Who is online

Users browsing this forum: No registered users and 3 guests