town coverage in 1.10 sometimes disappears

Got a problem with OpenTTD? Find some help here.

Moderator: OpenTTD Developers

Post Reply
sootynz
Traffic Manager
Traffic Manager
Posts: 181
Joined: 24 Jan 2007 02:07

town coverage in 1.10 sometimes disappears

Post by sootynz »

I've started to use the new feature town coverage a lot - it really helps the way I play, so thanks for implementing it. For each town, I have a bus/tram network serving the station and like to cover the whole town.

I'm not sure if this can be called a bug. However, when I set the town coverage, then move a road station towards a prospective site, the coverage display sometimes disappears - not all the time. It would be nice if the town coverage display, blue or red, stayed until I stopped it.

Also, would it be possible to have different coloured blues for the town coverage and the station coverage?

User avatar
odisseus
Traffic Manager
Traffic Manager
Posts: 131
Joined: 01 Nov 2017 21:19

Re: town coverage in 1.10 sometimes disappears

Post by odisseus »

I can confirm that this happens in the version 1.10.1, and since this problem is not mentioned in the 1.10.2 changelog, it's probably not fixed yet.

When the moving highlight around the station that is being placed overlaps with the coverage highlight of a town, the latter turns off. I find this quite annoying, because the feature becomes unusable when it is needed most.

LaChupacabra
Engineer
Engineer
Posts: 92
Joined: 08 Nov 2019 23:54

Re: town coverage in 1.10 sometimes disappears

Post by LaChupacabra »

odisseus wrote:
03 Jun 2020 06:16
I can confirm that this happens...
When the moving highlight around the station that is being placed overlaps with the coverage highlight of a town, the latter turns off.
It's not work like you write... The city range turns off when you approach the station build cursor to an existing station field. I have written about this and other problems related to the city and ststions range for some time in this topic.
I am sorry for may English. I know is bed.

Post Reply

Return to “OpenTTD Problems”

Who is online

Users browsing this forum: No registered users and 2 guests