Transport Tycoon Forums

The place to talk about Transport Tycoon
It is currently Wed May 22, 2019 1:52 am

All times are UTC




Post new topic  Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Sun Mar 10, 2019 8:48 am 
Offline
Engineer
Engineer

Joined: Sun Mar 10, 2019 1:45 am
Posts: 3
Good morning!

For 2 days I've been trying to change settings for my dedicated server. The settings are applied in the config.cfg, but not applied in the game. I couldn't find a solution either here in the forum or in the wiki. That's why I hope for your help.

At first I changed all settings as desired. When no change was made, I saved the config.cfg separately and reinstalled the server. Then I try to chang only single settings, for example, city names from English to German or the starting year. But the game is running with default settings.

What can this be?

Regards


Top
   
PostPosted: Sun Mar 10, 2019 10:27 am 
Offline
Route Supervisor
Route Supervisor
User avatar

Joined: Wed Jan 08, 2003 11:09 pm
Posts: 479
Location: Denmark
Usually the config file is named openttd.cfg, if you named yours differently are you sure you're passing the right filename to the -c commandline parameter?


Top
   
PostPosted: Sun Mar 10, 2019 10:44 am 
Offline
Engineer
Engineer

Joined: Sun Mar 10, 2019 1:45 am
Posts: 3
I didn't change the name if this file, so i think it isn't necessary to use the parameter.


Top
   
PostPosted: Sun Mar 10, 2019 2:07 pm 
Offline
Route Supervisor
Route Supervisor
User avatar

Joined: Wed Jan 08, 2003 11:09 pm
Posts: 479
Location: Denmark
Let's try again: If you want OpenTTD to find your config file without using commandline parameter, the name of the file must be "openttd.cfg".


Top
   
PostPosted: Sun Mar 10, 2019 2:07 pm 
Offline
OpenTTD Developer
OpenTTD Developer
User avatar

Joined: Wed Nov 07, 2007 10:44 pm
Posts: 9265
Location: Sol d
Make sure to have your server NOT running when you change the config file; OpenTTD makes a save of the settings upon terminating and might overwrite the changes you made while it was running.

Or use the -c configfilename flag to load from a non-default file which will not be overwritten when OpenTTD terminates.

_________________
Image
OpenTTD: manual | online content | translations | Wanted contributions and patches
#openttdcoop: blog | wiki | public server | DevZone | NewGRF web translator
DevZone - home of the free NewGRFs: OpenSFX | OpenMSX | OpenGFX | Swedish Rails | OpenGFX+ Trains|RV|Industries|Airports|Landscape | NML


Top
   
PostPosted: Sun Mar 10, 2019 3:47 pm 
Offline
Engineer
Engineer

Joined: Sun Mar 10, 2019 1:45 am
Posts: 3
Oh, I'm sorry. The filename is openttd.cfg and not config.cfg as I wrote above.

I just reinstalled the server again und stopped it immediately. Then I copied the openttd.cfg I've saved before and restarted the server - it works! This I also tried the last 2 days. Don't know why it's running now.

Thanks for your help!


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000-2019 phpBB Limited

Copyright © Owen Rudge/The Transport Tycoon Forums 2001-2019.
Hosted by Zernebok Hosting.