Installing the latest OpenTTD on Ubuntu fails for some reason

Got a problem with OpenTTD? Find some help here.

Moderator: OpenTTD Developers

Post Reply
gimel3830
Engineer
Engineer
Posts: 7
Joined: 23 Jan 2015 00:11

Installing the latest OpenTTD on Ubuntu fails for some reason

Post by gimel3830 »

Hello, I'm quite new on Ubuntu and it doesn't seem like OpenTTD is correctly installing on my computer. :shock:
I've been using Windows for my whole life until a few days ago when I suddenly wanted a small change..

I'm quite sure that I've downloaded the right .deb file. However, when tried to install it with Ubuntu Software (Centre), it showed 'No Software Source Included', and installed OpenTTD 1.5.3 instead, which seems like the latest version on the Software Centre itself.

So I tried to install it from the Terminal but that didn't work neither.

Could someone help me get the latest OpenTTD successfully? Thanks in advance. :bow: :bow:
Attachments
Screenshot from 2017-08-08 14-50-27.png
The screenshot taken when attempting to install it from the Terminal
(229.16 KiB) Not downloaded yet

User avatar
DeletedUser10
Traffic Manager
Traffic Manager
Posts: 209
Joined: 01 Jun 2017 10:03

Re: Installing the latest OpenTTD on Ubuntu fails for some reason

Post by DeletedUser10 »

Type

Code: Select all

sudo aptitude install libicu52
Then try again.
You can't install latest OTTD on Ubuntu Software or apt.
Instead, you have to install from the deb package, but libraries won't installed automatically, so you have to install them by yourself.
Sent from my Ubuntu 16.04 LTS

gimel3830
Engineer
Engineer
Posts: 7
Joined: 23 Jan 2015 00:11

Re: Installing the latest OpenTTD on Ubuntu fails for some reason

Post by gimel3830 »

ir1n1o57 wrote:Type

Code: Select all

sudo aptitude install libicu52
Then try again.
You can't install latest OTTD on Ubuntu Software or apt.
Instead, you have to install from the deb package, but libraries won't installed automatically, so you have to install them by yourself.
Thanks. I'll try that later and see if that works.

User avatar
DeletedUser10
Traffic Manager
Traffic Manager
Posts: 209
Joined: 01 Jun 2017 10:03

Re: Installing the latest OpenTTD on Ubuntu fails for some reason

Post by DeletedUser10 »

If you didn't install aptitude, apt is also OK.
Sent from my Ubuntu 16.04 LTS

agentw4b
Traffic Manager
Traffic Manager
Posts: 175
Joined: 14 Apr 2017 15:51
Location: Czech Republic

Re: Installing the latest OpenTTD on Ubuntu fails for some reason

Post by agentw4b »

gimel3830 wrote:
ir1n1o57 wrote:Type

Code: Select all

sudo aptitude install libicu52
Then try again.
You can't install latest OTTD on Ubuntu Software or apt.
Instead, you have to install from the deb package, but libraries won't installed automatically, so you have to install them by yourself.
Thanks. I'll try that later and see if that works.
I am not linux expert but I used this method in Ubuntu 14.04.5

first: ls /home/(your user)
-----------------------------------
wget https://binaries.openttd.org/releases/1 ... -amd64.deb
sudo apt-get install gdebi
sudo gdebi openttd-1.7.1-linux-ubuntu-trusty-amd64.deb
wget https://binaries.openttd.org/extra/open ... .2-all.zip
sudo unzip opengfx-0.5.2-all.zip
tar -xvf opengfx-0.5.2.tar
mv opengfx-0.5.2 ~/.openttd/baseset



(Openttd services)
wget https://bitbucket.org/frodus/openttd-in ... -1.1.1.zip
unzip openttd-init-1.1.1.zip -d openttd-init
sudo ln -s ~/openttd-init/openttd /etc/init.d/openttd
sudo chmod 755 ~/openttd-init/openttd
sudo update-rc.d openttd defaults

(Finally rename ~/openttd-init/config.example to config and edit the variables to suitable values.)

(firewall)
sudo apt-get ufw
sudo apt-get install ufw
sudo ufw allow 3979
sudo ufw reload

(start and stop)
/etc/init.d/openttd start
/etc/init.d/openttd stop
Owner and admin of servers:Experimental games 01 (92.63.57.152:3979), Experimental games 02 (92.63.57.152:3879), Experimental games 03 (92.63.57.152:3779), Experimental games 04 (92.63.57.152:3679), Experimental games 05 (92.63.57.152:3579).
My heightmaps: Flat Earth Map and United nations logo
My scenarios: Game Fallout 1,2,3 Map scenario
My gamescripts: City Founder GS

agentw4b
Traffic Manager
Traffic Manager
Posts: 175
Joined: 14 Apr 2017 15:51
Location: Czech Republic

Re: Installing the latest OpenTTD on Ubuntu fails for some reason

Post by agentw4b »

Ubuntu 17.04 :


first: ls /home/(your user)
-----------------------------------
wget https://binaries.openttd.org/releases/1 ... -amd64.deb
wget http://cz.archive.ubuntu.com/ubuntu/poo ... _amd64.deb
wget http://cz.archive.ubuntu.com/ubuntu/poo ... _amd64.deb
sudo apt-get install gdebi
sudo gdebi libicu52_52.1-3ubuntu0.7_amd64.deb
sudo gdebi libpng12-0_1.2.54-1ubuntu1_amd64.deb
sudo gdebi openttd-1.7.1-linux-ubuntu-trusty-amd64.deb
wget https://binaries.openttd.org/extra/open ... .2-all.zip
sudo unzip opengfx-0.5.2-all.zip
tar -xvf opengfx-0.5.2.tar
mv opengfx-0.5.2 ~/.openttd/baseset



(Openttd services)
wget https://bitbucket.org/frodus/openttd-in ... -1.1.1.zip
unzip openttd-init-1.1.1.zip -d openttd-init
sudo ln -s ~/openttd-init/openttd /etc/init.d/openttd
sudo chmod 755 ~/openttd-init/openttd
sudo update-rc.d openttd defaults

(Finally rename ~/openttd-init/config.example to config and edit the variables to suitable values.)

(firewall)
sudo apt-get ufw
sudo apt-get install ufw
sudo ufw allow 3979
sudo ufw reload

(start and stop)
/etc/init.d/openttd start
/etc/init.d/openttd stop
Owner and admin of servers:Experimental games 01 (92.63.57.152:3979), Experimental games 02 (92.63.57.152:3879), Experimental games 03 (92.63.57.152:3779), Experimental games 04 (92.63.57.152:3679), Experimental games 05 (92.63.57.152:3579).
My heightmaps: Flat Earth Map and United nations logo
My scenarios: Game Fallout 1,2,3 Map scenario
My gamescripts: City Founder GS

agentw4b
Traffic Manager
Traffic Manager
Posts: 175
Joined: 14 Apr 2017 15:51
Location: Czech Republic

Re: Installing the latest OpenTTD on Ubuntu fails for some reason

Post by agentw4b »

Ubuntu 18.04, Openttd 1.9.1 :


first: ls /home/(your user)
-----------------------------------

wget https://proxy.binaries.openttd.org/open ... -amd64.deb
sudo apt-get install gdebi
sudo gdebi openttd-1.9.1-linux-ubuntu-bionic-amd64.deb
wget https://binaries.openttd.org/extra/open ... .5-all.zip
tar -xvf opengfx-0.5.5.tar
mv opengfx-0.5.5 ~/.openttd/baseset



(Openttd services)
wget https://bitbucket.org/frodus/openttd-in ... -1.1.1.zip
unzip openttd-init-1.1.1.zip -d openttd-init
sudo ln -s ~/openttd-init/openttd /etc/init.d/openttd
sudo chmod 755 ~/openttd-init/openttd
sudo update-rc.d openttd defaults

(Finally rename ~/openttd-init/config.example to config and edit the variables to suitable values.)

(firewall)
sudo apt-get ufw
sudo apt-get install ufw
sudo ufw allow 3979
sudo ufw reload

(start and stop)
/etc/init.d/openttd start
/etc/init.d/openttd stop
Owner and admin of servers:Experimental games 01 (92.63.57.152:3979), Experimental games 02 (92.63.57.152:3879), Experimental games 03 (92.63.57.152:3779), Experimental games 04 (92.63.57.152:3679), Experimental games 05 (92.63.57.152:3579).
My heightmaps: Flat Earth Map and United nations logo
My scenarios: Game Fallout 1,2,3 Map scenario
My gamescripts: City Founder GS

agentw4b
Traffic Manager
Traffic Manager
Posts: 175
Joined: 14 Apr 2017 15:51
Location: Czech Republic

Re: Installing the latest OpenTTD on Ubuntu fails for some reason

Post by agentw4b »

I just updated the old tutorial for newer versions. Otherwise, I don't solve any problem :)
Owner and admin of servers:Experimental games 01 (92.63.57.152:3979), Experimental games 02 (92.63.57.152:3879), Experimental games 03 (92.63.57.152:3779), Experimental games 04 (92.63.57.152:3679), Experimental games 05 (92.63.57.152:3579).
My heightmaps: Flat Earth Map and United nations logo
My scenarios: Game Fallout 1,2,3 Map scenario
My gamescripts: City Founder GS

Post Reply

Return to “OpenTTD Problems”

Who is online

Users browsing this forum: No registered users and 4 guests