Server hosting problem

Got a problem with OpenTTD? Find some help here.

Moderator: OpenTTD Developers

Post Reply
Nick_B
Engineer
Engineer
Posts: 1
Joined: 08 May 2021 22:56

Server hosting problem

Post by Nick_B »

I haven't opened OpenTTD since after we got this new router from our internet company, before it was working fine with starting servers and running multiplayer games, now I have absolutely no idea what is going on. I opened ports and everything for the game to be able to port forward out and in, it still does nothing even with that. I've also tried using Hamachi, which is what I was using before because our old router was 10+ years old and didn't allow any kind of configuring, but with this new one I can configure it. Problem is, I can't even start a server in game. It gives me "could not start server" in a red box for literally any savegame I try to load.

Snip of my problem:

Image
rowdog
Engineer
Engineer
Posts: 67
Joined: 24 May 2017 12:51
Location: East Texas

Re: Server hosting problem

Post by rowdog »

Code: Select all

dbg: [net] getaddrinfo for hostname "192.168.254.255.3979", port 3978, address either IPv4 or IPv6 and socket type tcp failed: Name or service not known
That line jumped out at me because IPv4 addresses are "dotted quads" (4 sets of numbers separated by 3 dots) and that address has 5 sets of numbers separated by 4 dots, which is invalid. Also, the first part, 192.168.254.255 is the broadcast address, which means that it's never used to identify a single machine.

I could be totally wrong but my guess is that you entered the address wrong and that you meant to use something like 192.168.254.XXX:3979 but replace the XXX with the actual address of the machine. I haven't used Windows for some years now but I imagine you can still find your address with the ifconfig command.

The easiest way to start a multiplayer game is to let openttd figure out the address stuff for you. This is a snippet of an example start up from my Linux machine that allows connections from any network I'm attached to.

Code: Select all

openttd -D
dbg: [net] Starting dedicated version 1.10.3
dbg: [net] [core] starting network...
dbg: [net] [udp] initializing listeners
dbg: [net] [core] network online, multiplayer available
dbg: [net] Detected broadcast addresses:
dbg: [net] 0) 192.168.0.255
dbg: [net] [udp] closed listeners
dbg: [net] [udp] initializing listeners
dbg: [net] [udp] closed listeners
dbg: [net] [udp] initializing listeners
dbg: [net] starting listeners for clients
dbg: [net] [tcp] listening on IPv4 port 0.0.0.0:3979 (IPv4)
dbg: [net] [tcp] listening on IPv6 port [::]:3979 (IPv6)
dbg: [net] starting listeners for incoming server queries
dbg: [net] [udp] listening on IPv4 port 0.0.0.0:3979 (IPv4)
dbg: [net] [udp] listening on IPv6 port [::]:3979 (IPv6)
tl;dr: you probably typo'd `openttd -D 192.168.254.255.3979` instead of `openttd -D 192.168.254.???:3979` but `openttd -D` is even easier.
Post Reply

Return to “OpenTTD Problems”

Who is online

Users browsing this forum: No registered users and 4 guests