1st March 1967 - TTD Crashes!!!

Old messages from the Transport Tycoon forum at owenrudge.net.
Locked
TC

1st March 1967 - TTD Crashes!!!

Post by TC » 22 Oct 2002 15:24

I am having a serious problem with Transport Tycoon Deluxe. I am running the game under Windows XP with TTD patch version 1.81. When the game reaches 1st of March 1967, it crashes onto desktop and Windows XP reports a problem occurring with ttdloadw.ovl. Please help!

User avatar
orudge
Administrator
Administrator
Posts: 23995
Joined: 26 Jan 2001 20:18
Skype: orudge
Location: Banchory, UK
Contact:

Post by orudge » 22 Oct 2002 16:34

Someone else here had a problem with a game crashing at a later date. You could try and put the date forward a little bit with TTDX Editor, but other than that, there's not usually a lot you can do. :(

User avatar
spaceman-spiff
Retired Moderator
Retired Moderator
Posts: 20670
Joined: 28 Jul 2002 07:08
Location: Belgium
Contact:

Post by spaceman-spiff » 23 Oct 2002 04:47

i already had a look at 2 games with other dates, problem is the same,
changing dates didn't help
it's just that TTD sometimes has a problem with a 'stack' or 'registers' or 'overflow', i don't know

yesterday i had a crash problem , but i was able to fix it
i was managing an opponent, when i clicked on his HQ or on one of his trains , it crashed with an XP error reporting window
so i bought him out and then i could continue the game , perhaps i will have further crashes, who knows

i think Josef really needs a pc with XP on it, cause it's not that stable

other thing is, my problem can be caused by the fact that i try every new version, i can understand that when you always play with the same savegame , that at a certain point this game must get problems :?
Well, back to work, lot's of it in the near future

User avatar
spaceman-spiff
Retired Moderator
Retired Moderator
Posts: 20670
Joined: 28 Jul 2002 07:08
Location: Belgium
Contact:

Re: 1st March 1967 - TTD Crashes!!!

Post by spaceman-spiff » 23 Oct 2002 04:49

TC wrote:I am having a serious problem with Transport Tycoon Deluxe. I am running the game under Windows XP with TTD patch version 1.81. When the game reaches 1st of March 1967, it crashes onto desktop and Windows XP reports a problem occurring with ttdloadw.ovl. Please help!
could you send my a savegame, i want to try it !
=> spiff@pandora.be
Well, back to work, lot's of it in the near future

TiMMah!!!
Traffic Manager
Traffic Manager
Posts: 158
Joined: 20 Oct 2002 14:48
Location: Emmen, The Netherlands

Post by TiMMah!!! » 23 Oct 2002 05:54

I have Win98 on one computer, when I play my own scenario. It just crashes after 5 seconds.
What can that be?
Big signatures are annoying

supa
Engineer
Engineer
Posts: 12
Joined: 12 Oct 2002 10:54

Post by supa » 23 Oct 2002 08:38

It was me who was (and still is) experiencing same kind of problems. I still haven't managed to e-mail Josef so I don't have a solution yet (if there is one).

I wouldn't want to start a new game. I don't like the idea of having the same problem in the future.

First time my game crashed I lost 15+ years of gameplay, it kinda pissed me off ;<

User avatar
orudge
Administrator
Administrator
Posts: 23995
Joined: 26 Jan 2001 20:18
Skype: orudge
Location: Banchory, UK
Contact:

Post by orudge » 23 Oct 2002 10:52

I'd recommend you save your game at least once I year. I always save my game on the 1st January each year just out of habit, and whenever I'm going to do some big thing like buy an AI company or perform a big line change, etc, I save the game then.

TiMMah!!!
Traffic Manager
Traffic Manager
Posts: 158
Joined: 20 Oct 2002 14:48
Location: Emmen, The Netherlands

Post by TiMMah!!! » 23 Oct 2002 11:37

Well, that's why we have Autosave...
Big signatures are annoying

SHADOW-XIII

Re: 1st March 1967 - TTD Crashes!!!

Post by SHADOW-XIII » 23 Oct 2002 11:50

TC wrote:I am having a serious problem with Transport Tycoon Deluxe. I am running the game under Windows XP with TTD patch version 1.81. When the game reaches 1st of March 1967, it crashes onto desktop and Windows XP reports a problem occurring with ttdloadw.ovl. Please help!
Hi All ... owen i was have this problem ... Try turn on switch 'noinflation'
like this: noinflation on
It works for me, I dunno why but with this switch on game have no crahs at the end/start of new month

supa
Engineer
Engineer
Posts: 12
Joined: 12 Oct 2002 10:54

Post by supa » 25 Oct 2002 12:25

All: Yeah yeah, I know I should have saved more often. As people should take backup of their personal files and should change password every once in the while etc. etc. :) I was doing all kind of micromanagement and the time just flew, didn't think about saving.

Shadow: I have the noinflation switch turned on. Doesn't help.

Offtopic... For some reason this forum just cant remember my login-details, I have to login every time I visit here.. strange.

User avatar
orudge
Administrator
Administrator
Posts: 23995
Joined: 26 Jan 2001 20:18
Skype: orudge
Location: Banchory, UK
Contact:

Post by orudge » 25 Oct 2002 19:30

supa wrote:All: Yeah yeah, I know I should have saved more often. As people should take backup of their personal files and should change password every once in the while etc. etc. :) I was doing all kind of micromanagement and the time just flew, didn't think about saving.
Yes. Basically, when the Finances dialog pops up every year, I just press F3, ENTER, and get on with the same - it only takes a second. :)
Offtopic... For some reason this forum just cant remember my login-details, I have to login every time I visit here.. strange.
Do you have cookies enabled? If not, it can't remember who you are.

User avatar
spaceman-spiff
Retired Moderator
Retired Moderator
Posts: 20670
Joined: 28 Jul 2002 07:08
Location: Belgium
Contact:

Post by spaceman-spiff » 26 Oct 2002 03:44

Josef said that it's a know bug in TTD
it has something to do with subsidies and removing stations that have a subsidy

That's a known bug in TTD. It happens if a station that was part of a
subsidy is removed before the subsidy expires. Not much that can be done,
sorry. If you can, go back to an earlier savegame and don't remove that
station. Or if it's a competitor that removes that station, rebuild it
yourself before the gray sign disappears


But it can take a while before you find that station
So saving A LOT is very important
Well, back to work, lot's of it in the near future

User avatar
orudge
Administrator
Administrator
Posts: 23995
Joined: 26 Jan 2001 20:18
Skype: orudge
Location: Banchory, UK
Contact:

Post by orudge » 26 Oct 2002 07:39

Ah, I've experienced that bug - see my Bugs page for details.

User avatar
spaceman-spiff
Retired Moderator
Retired Moderator
Posts: 20670
Joined: 28 Jul 2002 07:08
Location: Belgium
Contact:

Post by spaceman-spiff » 28 Oct 2002 08:22

No i know i wasn't dreaming :wink:
i had that 'cannot remove obstacles on land' in my subsidies too
and shortly after it crashed

It's good to save each year, this way you can go back and check for the subsidies with stations that are greyed out, then you can rebuild them

I never needed the autosave function
Well, back to work, lot's of it in the near future

Locked

Return to “Owen's TT Station Forum (Archived Posts)”

Who is online

Users browsing this forum: No registered users and 2 guests