OpenTTD 0.6.3

OpenTTD is a fully open-sourced reimplementation of TTD, written in C++, boasting improved gameplay and many new features.

Moderator: OpenTTD Developers

Post Reply
Rubidium
OpenTTD Developer
OpenTTD Developer
Posts: 3815
Joined: 09 Feb 2006 19:15

OpenTTD 0.6.3

Post by Rubidium »

Today we have released the third bugfix release of the 0.6 series. As usual it contains many bugfixes, including fixes for a few desyncs.

However, unlike previous times we do not use sourceforge.net as primary source of distribution but our new webserver: http://www.openttd.org/download-stable

Changes since 0.6.2:
  • Fix: NewGRF VarAction 2 variable 43 for industries saw MP_VOID tiles as land tiles and was inefficient (r14417, r14416, r14415)
  • Fix: Possible buffer overrun/wrong parameter type passed to printf (r14414, r14397)
  • Fix: Generation seed set using -G was always overwritten by -g (r14408)
  • Fix: Do not allow extending signals by dragging in any direction other than the track direction [FS#2202] (r14013)
  • Fix: Invalid v->u.air.targetairport could cause crashes at several places [FS#2300] (r14383, r14344, r14343)
  • Fix: Moving the first vehicle of a train elsewhere might require a new unitnumber for the remaining chain which might not be available (r14384)
  • Fix: Trams jumping when reversing on a single trambit (like caused during road construction reworks) or when (manually) reversing in a corner [FS#1852] (r14371)
  • Fix: Multiheaded parts in free wagon chains weren't connected (could cause desyncs) (r14366, r14362)
  • Fix: [Win32] Some keypress combinations could be handled twice [FS#2206] (r14363)
  • Fix: The ownership of roadtiles was not properly set for very old savegames (including TTD's) making it impossible to remove some pieces of road [FS#2311] (r14359)
  • Fix: Desync due to randomly ordered vehicle hash by flooding and road vehicle overtake/following (r14356, r14258)
  • Fix: Signs were not updated on company bankrupcy/sell, and thus could have the colour of invalid player (r14348)
  • Fix: Delete the RenameSignWindow when 'its' sign is deleted (r14345)
  • Fix: Signs from old savegames were lost (causing little memory leaks) (r14340)
  • Fix: When a company was renamed and then manager was renamed before building anything, company name changed (r14328)
  • Fix: When you rename a town before building something and build something near that town your company would be called "<old townname> Transport" [FS#2251] (r14327)
  • Fix: Free any blocks that a helicopter may have on an oilrig when the helicopter gets forcefully removed (bankruptcy). For other airports this isn't needed as they can't be used by multiple companies [FS#2241] (r14324)
  • Fix: Possible assert when renaming removed waypoint (r14322)
  • Fix: Properly delete orders so the pool doesn't fill up (r14319)
  • Fix: Do not allow building road over level crossings and drive-through road stops in the wrong direction; do not allow adding roadtypes to non-drive through road stops; pay for all added road bits [FS#2268] (r14316, r14315, r14314, r14308)
  • Fix: Aircraft frozen above oil rig when the next order is invalid [FS#2244] (r14309)
  • Fix: [YAPF] Only reserve road slots for multistop when they are really reachable [FS#2294] (r14305)
  • Fix: One could be trying to get the station name of a station that is outside of the pool (r14297)
  • Fix: Default for sound effects and music volume should be in the valid range for that setting [FS#2286] (r14289)
  • Fix: Make small UFO aware of articulated RVs so they crash the complete vehicle instead of a small part of it (r14270)
  • Fix: Desyncs after deleting a waypoint because of explicit destructor call instead of using operator delete (r14265)
  • Fix: Merge keycode for "normal" 0-9 keys and keypad 0-9 keys so people do not get confused that the keypad does not work as expected [FS#2277] (r14260)
  • Fix: Clicking on the smallmap didn't break the "follow vehicle in main viewport" [FS#2269] (r14243)
  • Fix: The engine-purchase-list-sorter doubled running-cost and halfed capacity of double-headed engines [FS#2267] (r14239)
  • Fix: Feeder share was computed wrong when splitting cargo packet (r14234)
  • Fix: Signs (town name, station name, ...) could be too long for 8bit width in pixels (r14221)
  • Fix: 10 days != 6*2.5 days, effectively causing the payment graph to show the wrong data (r14219)
  • Fix: When determining length of a string with limited size, first check if we are not out of bounds already (r14204)
  • Fix: Properly update the current timetable's travel/wait times instead of only doing it for one vehicle in the shared order chain and only when some bit has not been set [FS#2236] (r14192)
  • Fix: Sprite payload skipping would not skip enough bytes in a very small subset of compressed sprites (r14191)
  • Fix: After applying NewGRF settings, all rail and road types were available as the engine availability check was performed too early (r14182)
  • Fix: Close all related vehicle lists when closing a station window (and not only the train list) (r14180)
  • Fix: RemoveOrderFromAllVehicles() did not mark enough windows dirty (r14179)
  • Fix: Incorrect cargo weights (r14144)
  • Fix: GetSlopeZ() gets a virtual coordinate, not a tile (r14139)
  • Fix: Close the 'manage vehicles' dropdown once the number of vehicles in the list reaches 0 [FS#2249] (r14133)
  • Fix: [strgen] Changing order of parameters {X:...} did not work for strings including some {StringY} (r14111)
  • Fix: Desync due to bubbles in toyland (r14110)
  • Fix: Make NewGRF action 0x06's changes persistent over the several loading stages [FS#1986] (r14102)
  • Fix: Make the 'Transfer Credit' display aware of the entire consist, not only the first vehicle (r14098)
  • Fix: Do not flood a NewGRF industry when it implicitly tells that it wants to be build on water (land shape flags bit 5) [FS#2230] (r14093)
  • Fix: The vehicle window of articulated road vehicles would show the clone/refit button when the vehicle was not completely stopped in the depot (r14090)
  • Fix: Flawed parsing of words (as in 2 bytes) in GRF strings due to sign extension [FS#2228] (r14087)
  • Fix: Division by 0 in NewAI [FS#2226] (r14062)
  • Fix: NewGRF callback 23 did not use the NewGRF compatible text stack [FS#2224] (r14058)
  • Fix: NewGRF text stack's "push word" didn't move the data around properly (r14057)
  • Fix: Long strings in the edit box would cause OpenTTD to stop drawing the string. This is especially noticable with low resolutions and the chat input box (r14054)
  • Fix: [OSX] changed the condition for selecting 8 or 32 bpp blitter by default. Now we will pick 32 bpp if no 8 bpp fullscreen resolutions are available on the main display (the one with the dock) (r14032)
  • Fix: Crash when the AI tries to find the depot of an airport that doesn't have a depot [FS#2190] (r13999)
  • Fix: MSVC cannot handle changed files in the prebuild event, so make the version determination a separate subproject [FS#2004] (r13998)
  • Fix: The dedicated console removed any character that was not a printable ASCII character instead. Now it allows UTF8 formated strings too [FS#2189] (r13992)
  • Fix: Resetting construction stage counter reset more than it should (r13981)
  • Fix: Wrong tooltip for the industry directory's list [FS#2178] (r13917)

Wold
Transport Coordinator
Transport Coordinator
Posts: 318
Joined: 03 Aug 2006 19:32
Skype: woldy_bg
Location: Bulgaria

Re: OpenTTD 0.6.3

Post by Wold »

Thanks!
Image

User avatar
Barmybill
Engineer
Engineer
Posts: 95
Joined: 11 Jul 2008 08:58
Location: England

Re: OpenTTD 0.6.3

Post by Barmybill »

Wow. Its amazing how much work goes into even a small release. Users (like me) should always bear in mind how much you guys have achieved.

User avatar
Zephyris
Tycoon
Tycoon
Posts: 2831
Joined: 16 May 2007 16:59

Re: OpenTTD 0.6.3

Post by Zephyris »

I find this most amazing:
...unlike previous times we do not use sourceforge.net as primary source of distribution but our new webserver...
It just goes to show how much support this project has! Keep up the great work, it is very much appreciated!

User avatar
Nite Owl
Tycoon
Tycoon
Posts: 1889
Joined: 06 Mar 2007 19:32
Location: In The Dark

Re: OpenTTD 0.6.3

Post by Nite Owl »

A grateful community emits a satisfied sigh. I know I did.
Humor is the second most subjective thing on the planet
------------------------------------------------------------
Brevity is the soul of wit and obscenity is its downfall
--------------------------------------------------------
Good Night And Good Luck - Read You Soon

UltimateSephiroth
Engineer
Engineer
Posts: 5
Joined: 29 Jan 2008 17:53

Re: OpenTTD 0.6.3

Post by UltimateSephiroth »

Is it just me/my laptop or has the strgen utility stopped working? The language files I've compiled with it do not appear in the settings of the game and if I put the name of the custom language file into the openttd.cfg file, it reverts back to Finnish (which I usually use). strgen does not throw up any errors.

User avatar
Mr. X
Tycoon
Tycoon
Posts: 11501
Joined: 20 Sep 2004 22:45
Location: Black Mesa Research Facility - New Mexico
Contact:

Re: OpenTTD 0.6.3

Post by Mr. X »

Didn't notice this topic! :o

Good work guys! :bow:
Image
Authority is something you deserve, not something you impose. -Wile E. Coyote (TT-Forums member)

Hatsen
Engineer
Engineer
Posts: 4
Joined: 17 Apr 2008 13:34
Skype: Hatsen2000
Location: Kolding, Denmark

Re: OpenTTD 0.6.3

Post by Hatsen »

It's just amazing! :D

User avatar
Napoleon9th
Engineer
Engineer
Posts: 6
Joined: 20 May 2007 14:39
Location: Bucharest, Romania

Re: OpenTTD 0.6.3

Post by Napoleon9th »

UltimateSephiroth wrote:Is it just me/my laptop or has the strgen utility stopped working? The language files I've compiled with it do not appear in the settings of the game and if I put the name of the custom language file into the openttd.cfg file, it reverts back to Finnish (which I usually use). strgen does not throw up any errors.
Bump. No answer yet? I am getting (what i think is) a similar issue with the current 0.7.0 version. I'm also going to post a bug on flyspray, but first i'd like to know if the community here already knows about this...

Yexo
Tycoon
Tycoon
Posts: 3653
Joined: 20 Dec 2007 12:49

Re: OpenTTD 0.6.3

Post by Yexo »

Napoleon9th wrote:
UltimateSephiroth wrote:Is it just me/my laptop or has the strgen utility stopped working? The language files I've compiled with it do not appear in the settings of the game and if I put the name of the custom language file into the openttd.cfg file, it reverts back to Finnish (which I usually use). strgen does not throw up any errors.
Bump. No answer yet? I am getting (what i think is) a similar issue with the current 0.7.0 version. I'm also going to post a bug on flyspray, but first i'd like to know if the community here already knows about this...
If strgen really had stopped working there wouldn't be any releases at all. Conclusion: it's something else.

Post Reply

Return to “General OpenTTD”

Who is online

Users browsing this forum: No registered users and 5 guests