Trying to build OpenGFX, "Please install grfcodec"

Discussions about the technical aspects of graphics development, including NewGRF tools and utilities.

Moderator: Graphics Moderators

Post Reply
User avatar
Erato
Director
Director
Posts: 575
Joined: 25 May 2015 09:09
Location: The Netherlands

Trying to build OpenGFX, "Please install grfcodec"

Post by Erato »

Hey guys,

I'm trying to build OpenGFX so I can insert my own sprites for the main menu, and I got the following error:

Code: Select all

Cannot create obg files without grfid. Please install grfcodec, and try again. Aborting.
Makefile:356: recipe for target 'opengfx.obg' failed
make: *** [opengfx.obg] Error 1
I understand that I need to install grfcodec, but I have no idea what I need to do with the files downloaded from here: https://www.openttd.org/downloads/grfco ... atest.html
I use Bash on Ubuntu on Windows, so I reckoned I needed the Linux version, but I don't know where to put the files or to let the system know I have them.

So how do I install GRFcodec?

Thanks in advance,
Erato
No pics no clicks. Seriously.
ImageImageImageImageImageImageImage
Eddi
Tycoon
Tycoon
Posts: 7582
Joined: 17 Jan 2007 00:14

Re: Trying to build OpenGFX, "Please install grfcodec"

Post by Eddi »

you unpack it somewhere that is in your PATH
You might not exactly be interested in Ferion, but if you are, have fun :)
Post Reply

Return to “NewGRF Technical Discussions”

Who is online

Users browsing this forum: No registered users and 0 guests