Page 1 of 1

Trying to build OpenGFX, "Please install grfcodec"

Posted: 04 Jan 2021 02:58
by Erato
Hey guys,

I'm trying to build OpenGFX so I can insert my own sprites for the main menu, and I got the following error:

Code: Select all

Cannot create obg files without grfid. Please install grfcodec, and try again. Aborting.
Makefile:356: recipe for target 'opengfx.obg' failed
make: *** [opengfx.obg] Error 1
I understand that I need to install grfcodec, but I have no idea what I need to do with the files downloaded from here: https://www.openttd.org/downloads/grfco ... atest.html
I use Bash on Ubuntu on Windows, so I reckoned I needed the Linux version, but I don't know where to put the files or to let the system know I have them.

So how do I install GRFcodec?

Thanks in advance,
Erato

Re: Trying to build OpenGFX, "Please install grfcodec"

Posted: 04 Jan 2021 18:16
by Eddi
you unpack it somewhere that is in your PATH