couldn't find library 'pathfinder.road' with verison 3

Discuss the new AI features ("NoAI") introduced into OpenTTD 0.7, allowing you to implement custom AIs, and the new Game Scripts available in OpenTTD 1.2 and higher.

Moderator: OpenTTD Developers

Post Reply
lewcasthunder
Engineer
Engineer
Posts: 2
Joined: 27 Jan 2021 17:05

couldn't find library 'pathfinder.road' with verison 3

Post by lewcasthunder »

Hi,

Total newbie here. Sorry if this has been asked before, I've done a search and not found anything. I have download a few AI's and A LOT of them are coming back with the error "couldn't find library 'pathfinder.road' with verison 3" resulting in the opponents being unable to do anything except lose money to interest payments. Is there a known fix for this? (presumably I'm just missing something obvious)
Firrel
Engineer
Engineer
Posts: 51
Joined: 13 Aug 2019 17:06

Re: couldn't find library 'pathfinder.road' with verison 3

Post by Firrel »

lewcasthunder wrote: 27 Jan 2021 17:09 Hi,

Total newbie here. Sorry if this has been asked before, I've done a search and not found anything. I have download a few AI's and A LOT of them are coming back with the error "couldn't find library 'pathfinder.road' with verison 3" resulting in the opponents being unable to do anything except lose money to interest payments. Is there a known fix for this? (presumably I'm just missing something obvious)
You need to download it manually because the dependencies are not set properly for the AIs. It was also asked quite recently here.
[+] Spoiler
Snímka.PNG
Snímka.PNG (17.09 KiB) Viewed 201 times
lewcasthunder
Engineer
Engineer
Posts: 2
Joined: 27 Jan 2021 17:05

Re: couldn't find library 'pathfinder.road' with verison 3

Post by lewcasthunder »

Firrel wrote: 27 Jan 2021 18:56
lewcasthunder wrote: 27 Jan 2021 17:09 Hi,

Total newbie here. Sorry if this has been asked before, I've done a search and not found anything. I have download a few AI's and A LOT of them are coming back with the error "couldn't find library 'pathfinder.road' with verison 3" resulting in the opponents being unable to do anything except lose money to interest payments. Is there a known fix for this? (presumably I'm just missing something obvious)
You need to download it manually because the dependencies are not set properly for the AIs. It was also asked quite recently here.
[+] Spoiler
Snímka.PNG
Thankyou, sorted it out
Post Reply

Return to “OpenTTD AIs and Game Scripts”

Who is online

Users browsing this forum: No registered users and 6 guests