Transport Tycoon Forums

The place to talk about Transport Tycoon
It is currently Fri Nov 24, 2017 12:01 am

All times are UTC




Post new topic  Reply to topic  [ 6 posts ] 
Author Message
 Post subject: AI help!
PostPosted: Mon Jun 12, 2017 2:15 am 
Offline
Engineer
Engineer

Joined: Mon Jun 12, 2017 2:08 am
Posts: 3
Good day. Newbie here. I downloaded a bunch of AIs from Bananas and the libraries they require as stated in the error log. However I cannot make these work. I cannot download it directly using the "Check online content" cause we don't have an internet connection at home. Can you please provide me with step-by-step procedures on how to make AIs work if they're downloaded from the forums or other sources? Screenshots will really help. Tried unpacking the libraries for the tar file, but they didn't work at all. Thanks!


Top
   
 Post subject: Re: AI help!
PostPosted: Mon Jun 12, 2017 9:04 am 
Offline
Chairman
Chairman

Joined: Sat Jul 18, 2009 5:54 pm
Posts: 873
How exactly did you download those AIs?

The most reliable way to download libraries is from here: http://noai.openttd.org/downloads/Libraries/
Put the .tar files (not the .tar.gz files!) in your Documents/OpenTTD/ai/library directory. No need to unpack the .tar files (although they should work even if you unpack them).

Keep us updated if you still have any problems :)


Top
   
 Post subject: Re: AI help!
PostPosted: Mon Jun 12, 2017 11:27 am 
Offline
Engineer
Engineer

Joined: Mon Jun 12, 2017 2:08 am
Posts: 3
Thanks for your response.
Yah, I think I got confused between noai and Bananas. I think I dowloaded the AIs from noai, while the libraries were from Bananas. When I unpacked the library tar.gz to .tar files, the tar files were named with numbers, not the library name. Is that supposed to happen?


Top
   
 Post subject: Re: AI help!
PostPosted: Mon Jun 12, 2017 11:51 am 
Offline
Chairman
Chairman

Joined: Sat Jul 18, 2009 5:54 pm
Posts: 873
I actually checked it now, the tar.gz files indeed become something like 1234.tar when you unpack them (at least if you download from noai.openttd.org, this is not the case when you use the ingame content downloader). That is not a problem, they should still work if you place them in the correct directory. You can even rename the .tar files to something more descriptive if you like.


Top
   
 Post subject: Re: AI help!
PostPosted: Mon Jun 12, 2017 12:24 pm 
Offline
Engineer
Engineer

Joined: Mon Jun 12, 2017 2:08 am
Posts: 3
The numbered .tar files don't work, even under the library directory in the same folder as that of my AIs. I can't figure out how to do this.


Top
   
 Post subject: Re: AI help!
PostPosted: Mon Jun 12, 2017 1:13 pm 
Offline
Chairman
Chairman

Joined: Sat Jul 18, 2009 5:54 pm
Posts: 873
They should be in the ai/library directory, not the same directory as the AIs.

Are the AIs still missing the libraries? Are they missing the same libraries as before? Did you download the correct versions of the libraries? So, for example, if they say they need SuperLib v38, then download v38, not v40. Could you show a screenshot of the AI debug window with the error message, also with the current contents of your ai directory?


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: Google Adsense [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000-2017 phpBB Limited

Copyright © Owen Rudge/The Transport Tycoon Forums 2001-2017.
Hosted by Zernebok Hosting.