ChooChoo, a train network AI

Discuss the new AI features ("NoAI") introduced into OpenTTD 0.7, allowing you to implement custom AIs, and the new Game Scripts available in OpenTTD 1.2 and higher.

Moderator: OpenTTD Developers

Transport Coordinator
Transport Coordinator
Posts: 291
Joined: 26 Feb 2015 00:52

Re: ChooChoo, a train network AI

Post by xarick »

the index 'find' does not exist
Unnamed, 1955-07-31.png
(43.45 KiB) Not downloaded yet
R25-G21 - ChooChoo vs PathZilla - 7,463 days.sav
(3.43 MiB) Downloaded 101 times
Formerly known as Samu
User avatar
Redirect Left
Posts: 6739
Joined: 22 Jan 2005 19:31
Location: Wakefield, West Yorkshire

Re: ChooChoo, a train network AI

Post by Redirect Left »

I've also had this just now with find error, on a map with lots of AIs and me spectating them.
2019-12-12 13_26_16-OpenTTD jgrpp-0.32.2.png
2019-12-12 13_26_16-OpenTTD jgrpp-0.32.2.png (45.05 KiB) Viewed 1903 times
Unfortunately the author has gone AFK for over 2 years at this point, so we might be on our own. Unless someone heree knows how to fix it, i've tried numerous times but i can't get the AI programming language down, it's very confusing and non-sensical to me, otherwise i'd have a good go at fixing numerous issues with lots of old AIs.
Worst Behaved IRC Member of 2008, 2009 & 2010 - Go Me!
Posts: 2
Joined: 11 Jan 2020 13:11

Re: ChooChoo, a train network AI

Post by mando »

I was trying out some AIs, including ChooChoo and noticed it wasn't working. I fixed two breaking bugs:
  1. Updated road pathfinding library version from 3 to 4
  2. Checked that a returned vehicle name is not null before doing name.find("X")
    I have attached a patch, and a new updated tarball.
    (867 Bytes) Downloaded 106 times
    (180 KiB) Downloaded 105 times
    User avatar
    Donald Duck
    Posts: 4
    Joined: 24 Apr 2020 07:05

    Re: ChooChoo, a train network AI

    Post by Donald Duck »

    I tried using this AI and got some errors:

    Posts: 100
    Joined: 12 May 2013 22:28
    Location: Argentina

    Re: ChooChoo, a train network AI

    Post by HGus »

    That is not an error from AI, but your installation. Use the update function from ingame or install manually Pathfinder library version 3
    Post Reply

    Return to “OpenTTD AIs and Game Scripts”

    Who is online

    Users browsing this forum: No registered users and 5 guests