OtviAI (version 415)

Discuss the new AI features ("NoAI") introduced into OpenTTD 0.7, allowing you to implement custom AIs, and the new Game Scripts available in OpenTTD 1.2 and higher.

Moderator: OpenTTD Developers

Kogut
Tycoon
Tycoon
Posts: 2493
Joined: 26 Aug 2009 06:33
Location: Poland

Re: OtviAI (version 379)

Post by Kogut » 11 Nov 2010 11:02

bugbugbug
Attachments
Przechwytywanie.PNG
(233.22 KiB) Downloaded 2 times
Correct me If I am wrong - PM me if my English is bad
AIAI - AI for OpenTTD

Maninthebox
Engineer
Engineer
Posts: 107
Joined: 08 Aug 2008 11:35
Contact:

Re: OtviAI (version 379)

Post by Maninthebox » 11 Nov 2010 13:09

Found and fixed. Thanks! I guess I will have to release a bugfix release soon now :)

Maninthebox
Engineer
Engineer
Posts: 107
Joined: 08 Aug 2008 11:35
Contact:

Re: OtviAI (version 379)

Post by Maninthebox » 04 Jan 2011 13:07

Now that I've had a bit of holidays: a bugfix release in bananas! Nothing new, just bug fixes to the bugs reported here. Thanks all for the feedback and reporting of those bugs!

User avatar
planetmaker
OpenTTD Developer
OpenTTD Developer
Posts: 9278
Joined: 07 Nov 2007 22:44
Location: Sol d

Re: OtviAI (version 379)

Post by planetmaker » 04 Jan 2011 13:18

Maninthebox wrote:Nothing new, just bug fixe
Don't belittlet that, it's IMHO not less important; actually it's even more important and valuable as only that ensures a good gaming experience. Many features are no fun, if they're unusable due to crashes... Thumbs up and thanks for your nice AI and keeping it updated :-)

Hephi
Engineer
Engineer
Posts: 69
Joined: 25 Oct 2009 09:56
Location: Belgium

Re: OtviAI (version 383)

Post by Hephi » 07 Jan 2011 16:48

Image


When using OtviAI version 383 and the 2CC train set 2.0 beta 3 (plus chimaera addon and subway set)

It seems to have problems adding wagons to the created engine. The ERR_UNKNOWN are probably GRF errors
trying to attach the 'multiple unit wagon' to an engine that does not support it. Resulting in a train with no
wagons being build. (having the same problem when testing my own AI with 2CC and don't know an easy fix though)

The two bottom errors seem to be handled correctly as the bus stop actually got build and are not part of this bug report.
--------------------------------------------------
MailAI, a casual postal service for openTTD.
--------------------------------------------------

Hephi
Engineer
Engineer
Posts: 69
Joined: 25 Oct 2009 09:56
Location: Belgium

Re: OtviAI (version 383)

Post by Hephi » 10 Jan 2011 15:11

Image
--------------------------------------------------
MailAI, a casual postal service for openTTD.
--------------------------------------------------

Snake.Bite
Engineer
Engineer
Posts: 1
Joined: 12 Feb 2011 14:53

Re: OtviAI (version 383)

Post by Snake.Bite » 12 Feb 2011 14:59

Same problem as Hephi has i have here.
Attachments
Genopsis Transport, 6th Feb 1968.sav
Savegame with the problem, dunno if helpfull
(1.12 MiB) Downloaded 110 times
err.png
Screenshot of the problem
err.png (15.72 KiB) Viewed 3825 times

User avatar
planetmaker
OpenTTD Developer
OpenTTD Developer
Posts: 9278
Joined: 07 Nov 2007 22:44
Location: Sol d

Re: OtviAI (version 383)

Post by planetmaker » 19 Apr 2011 20:38

That problem as mentioned in the posting above seems to happen more often. It just occured here, too.

User avatar
Zuu
OpenTTD Developer
OpenTTD Developer
Posts: 4553
Joined: 09 Jun 2003 18:21
Location: /home/sweden

Re: OtviAI (version 383)

Post by Zuu » 19 Apr 2011 21:00

I've also received the same error when running 10-20 year long games.
My OpenTTD contributions (AIs, Game Scripts, patches, OpenTTD Auto Updater, and some sprites)
Junctioneer (a traffic intersection simulator)

Maninthebox
Engineer
Engineer
Posts: 107
Joined: 08 Aug 2008 11:35
Contact:

Re: OtviAI (version 383)

Post by Maninthebox » 20 Apr 2011 07:53

I think I know what the problem is; should have some time during eastern etc. to fix that :)

User avatar
planetmaker
OpenTTD Developer
OpenTTD Developer
Posts: 9278
Joined: 07 Nov 2007 22:44
Location: Sol d

Re: OtviAI (version 383)

Post by planetmaker » 20 Apr 2011 09:21

Maninthebox wrote:I think I know what the problem is; should have some time during eastern etc. to fix that :)
sounds good. I shall be looking forward to it ;-)

Maninthebox
Engineer
Engineer
Posts: 107
Joined: 08 Aug 2008 11:35
Contact:

Re: OtviAI (version 395)

Post by Maninthebox » 24 Apr 2011 17:59

As promised: the Eastern edition is out :) The accidental easter egg also known as bug got removed. The bug was in the handling of passengers from oil rigs, so you only notice it in long temperate climate games and then only sometimes. I also made the TODO list longer with things I think I should improve and/or add :)

As usual: it can be found in bananas and in the first post in this thread.

User avatar
Zuu
OpenTTD Developer
OpenTTD Developer
Posts: 4553
Joined: 09 Jun 2003 18:21
Location: /home/sweden

Re: OtviAI (version 395)

Post by Zuu » 24 Apr 2011 21:16

Glad that you have taken your time to fix this stability issue with Otvi as it is a really good AI.
My OpenTTD contributions (AIs, Game Scripts, patches, OpenTTD Auto Updater, and some sprites)
Junctioneer (a traffic intersection simulator)

Maninthebox
Engineer
Engineer
Posts: 107
Joined: 08 Aug 2008 11:35
Contact:

Re: OtviAI (version 395)

Post by Maninthebox » 28 Apr 2011 14:15

Doh! There was some test code left behind in the uploaded version 395, so it was only building cargo routes and neglecting all passengers and mail. If you got version 395: it's time to update again :)

Felix Atagong
Engineer
Engineer
Posts: 45
Joined: 16 Apr 2007 19:50
Location: Louvain
Contact:

Re: OtviAI (version 396)

Post by Felix Atagong » 23 Jul 2011 11:49

'nother bug, this time with version 396
Attachments
Green Is The Colour, 27 Aug 1871.png
(16.99 KiB) Downloaded 1 time

Maninthebox
Engineer
Engineer
Posts: 107
Joined: 08 Aug 2008 11:35
Contact:

Re: OtviAI (version 396)

Post by Maninthebox » 11 Jan 2012 15:09

Ehm... I see I'm a bit late with fixing this bug :oops:

I remember having looked at the bug before. About 10 minutes before I went to a blind date with my now girlfriend and somehow forgot about the bug :P

So: fixed in 397 :)

Maninthebox
Engineer
Engineer
Posts: 107
Joined: 08 Aug 2008 11:35
Contact:

Re: OtviAI (version 398)

Post by Maninthebox » 12 Jan 2012 14:30

After testing yesterday's version, I quickly noticed two bugs that have been in there for a while already I think:
1 fix: don't build the same industry route twice
2 fix: don't mix up town and industry indexes

Version 398 fixes these and should improve performance :) Planning a route over a distance of 600 because you used a town index in the industry lists hurts a lot...

Kogut
Tycoon
Tycoon
Posts: 2493
Joined: 26 Aug 2009 06:33
Location: Poland

Re: OtviAI (version 398)

Post by Kogut » 18 Jan 2012 13:44

Maybe it was fixed, but Otviai 396 creates giant traffic jam: example. Save available on request.
Attachments
Przechwytywanie.PNG
(430.29 KiB) Downloaded 1 time
Correct me If I am wrong - PM me if my English is bad
AIAI - AI for OpenTTD

Maninthebox
Engineer
Engineer
Posts: 107
Joined: 08 Aug 2008 11:35
Contact:

Re: OtviAI (version 398)

Post by Maninthebox » 18 Jan 2012 13:51

That looks like what I fixed in 397: I accidentally built the same industry route a few times as you can see in your picture: there's multiple stations around the oil well and OtviAI is in heavy competition with eh... itself :P

Steffl
Engineer
Engineer
Posts: 103
Joined: 23 Feb 2010 15:44

Re: OtviAI (version 398)

Post by Steffl » 29 Feb 2012 08:02

Hi,
I have a bugreport for you.
OTVI version 398.
Attachments
Error.png
(321.36 KiB) Downloaded 1 time

Post Reply

Return to “OpenTTD AIs and Game Scripts”

Who is online

Users browsing this forum: No registered users and 2 guests