Hg connection to openttdcoop.org

Forum for technical discussions regarding development. If you have a general suggestion, problem or comment, please use one of the other forums.

Moderator: OpenTTD Developers

Post Reply
McZapkie
Tycoon
Tycoon
Posts: 1175
Joined: 18 Jan 2014 18:10

Hg connection to openttdcoop.org

Post by McZapkie » 09 Mar 2019 11:15

Could anybody refresh my volatile memory, how properly establish mercurial push-pull connection from local host to opettdcoop.org?
I generated RSA key, press reset on my account page, but how to upload new key here?
What I should to change/update/set, beside this?

User avatar
planetmaker
OpenTTD Developer
OpenTTD Developer
Posts: 9278
Joined: 07 Nov 2007 22:44
Location: Sol d

Re: Hg connection to openttdcoop.org

Post by planetmaker » 09 Mar 2019 11:55

McZapkie wrote:Could anybody refresh my volatile memory, how properly establish mercurial push-pull connection from local host to opettdcoop.org?
I generated RSA key, press reset on my account page, but how to upload new key here?
What I should to change/update/set, beside this?
Updating your ssh key is done manually. Open a ticket at the devzone or attach your public key here and I will install it there for your convenience.

McZapkie
Tycoon
Tycoon
Posts: 1175
Joined: 18 Jan 2014 18:10

Re: Hg connection to openttdcoop.org

Post by McZapkie » 11 Mar 2019 01:24

Everything works now, thank you.

McZapkie
Tycoon
Tycoon
Posts: 1175
Joined: 18 Jan 2014 18:10

Re: Hg connection to openttdcoop.org

Post by McZapkie » 31 Mar 2019 14:28

One more hg related question.
I created new project, but repository https://dev.openttdcoop.org/projects/eot/repository was not created automatically, as it is described in openttdcoop manual.
I initiated new hg project locally, but cant push it, I can't pull anything from server either.
I can resemble, that I run into similar issue before, but don't remember how to solve it (I think pressing 'new repository' in settings is not a good idea).
Any help appreciated...
My experimental openTTD server: 149.156.194.203:3979 non-standard client, now testing: JGRPP http://tiny.pl/ggnch
Projects: Reproducible Map Generation patch, NewGRFs: Manpower industries, PolTrams, Polroad, 600mm narrow gauge, preindustrial houses, wired, ECS industry extension, V4 CEE train set.
Addicted to freeciv longturn.

frosch
OpenTTD Developer
OpenTTD Developer
Posts: 979
Joined: 20 Dec 2006 13:31
Location: Aschaffenburg

Re: Hg connection to openttdcoop.org

Post by frosch » 31 Mar 2019 21:32

DevZone has some kind of chicken-egg problem when creating new projects.
The trick is to *not* request a repository when creating the project, but to enable the repository after the project has been created.

Anyway, EoT is fixed now.
⢇⡸⢸⠢⡇⡇⢎⡁⢎⡱⢸⡱⢸⣭⠀⢸⢜⢸⢸⣀⢸⣀⢸⣭⢸⡱⠀⢰⠭⡆⣫⠰⣉⢸⢸⠀⢰⠭⡆⡯⡆⢹⠁⠀⢐⠰⡁

McZapkie
Tycoon
Tycoon
Posts: 1175
Joined: 18 Jan 2014 18:10

Re: Hg connection to openttdcoop.org

Post by McZapkie » 31 Mar 2019 22:28

Thanks, I get it. Noted and bookmarked for future reference, to avoid deja vu :)

McZapkie
Tycoon
Tycoon
Posts: 1175
Joined: 18 Jan 2014 18:10

Re: Hg connection to openttdcoop.org

Post by McZapkie » 05 Apr 2019 08:37

There is no repository, and seems that is is global problem (for all projects hosted by dev.openttdcoop.org)

User avatar
planetmaker
OpenTTD Developer
OpenTTD Developer
Posts: 9278
Joined: 07 Nov 2007 22:44
Location: Sol d

Re: Hg connection to openttdcoop.org

Post by planetmaker » 05 Apr 2019 10:20

The Redmine front-end was having issues (but that controls the write-access via ssh as well).
The repositories themselves are actually on another VM and were unaffected. Their alternative address (which is normally is read-only) is https://hg.openttdcoop.org/

By now everything is working as normal again. Thanks for the report.

Post Reply

Return to “OpenTTD Development”

Who is online

Users browsing this forum: No registered users and 4 guests