Strgen is not working

Forum for technical discussions regarding development. If you have a general suggestion, problem or comment, please use one of the other forums.

Moderator: OpenTTD Developers

Post Reply
Stabilitronas
Engineer
Engineer
Posts: 4
Joined: 29 Jan 2012 10:39

Strgen is not working

Post by Stabilitronas » 29 Jan 2012 10:48

Hello everyone,

could anybody help me? I can't get strgen to work. When I try to compile a language file, it just spits a lot of "4470: error: Undefined command 'WEIGHT_LONG'" errors (also 'TINY_FONT', 'CURRENCY_SHORT' and others). I used downloaded version of strgen, released 2011-05-07. Perhaps it is outdated? Could somebody upload a newer version (or send it to me)?

Thanks in advance,
Simon

Yexo
Tycoon
Tycoon
Posts: 3653
Joined: 20 Dec 2007 12:49

Re: Strgen is not working

Post by Yexo » 29 Jan 2012 14:08

That version is quite old and indeed outdated. You could compile your own version from in the meantime or wait until a new version is compiled. Hopefully it'll be fixed soon.

Stabilitronas
Engineer
Engineer
Posts: 4
Joined: 29 Jan 2012 10:39

Re: Strgen is not working

Post by Stabilitronas » 29 Jan 2012 14:30

Well, I don't want to set all the OpenTTD develepment environment up (unless I am extremely lucky, that process would certainly require a lot of efforts) just to compile one small utility. A regular OpenTTD developer could do that in minutes...

Yexo
Tycoon
Tycoon
Posts: 3653
Joined: 20 Dec 2007 12:49

Re: Strgen is not working

Post by Yexo » 29 Jan 2012 14:33

Yes, I can compile a linux binary for you within minutes. However you haven't even posted which OS you use, so I'll guess and say windows. In any case, I've notified our SysOp, so hopefully he'll fix the compilation of strgen on the compile farm. That would mean you can download the most recent version of strgen from http://www.openttd.org/en/download-strgen again.

Stabilitronas
Engineer
Engineer
Posts: 4
Joined: 29 Jan 2012 10:39

Re: Strgen is not working

Post by Stabilitronas » 29 Jan 2012 19:51

Yep, Windows :) Anyway, thanks for helping!

jawsper
Engineer
Engineer
Posts: 20
Joined: 08 Jun 2004 00:02
Location: Netherlands

Re: Strgen is not working

Post by jawsper » 30 Jan 2012 20:48

Strgen r23740 for windows
Attachments
strgen-r23740-windows-win32.zip
(141.06 KiB) Downloaded 55 times
Patch: change finances window grouping
Patch: Tracking viewport

Warning: Unexpected end of file reached.

Stabilitronas
Engineer
Engineer
Posts: 4
Joined: 29 Jan 2012 10:39

Re: Strgen is not working

Post by Stabilitronas » 01 Feb 2012 07:19

Nice. Looks like it's working. Thanks!

Post Reply

Return to “OpenTTD Development”

Who is online

Users browsing this forum: Google [Bot] and 2 guests