Split the "Warn if vehicle is lost" setting by vehicle type

Got an idea for OpenTTD? Post it here!

Moderator: OpenTTD Developers

Post Reply
User avatar
Donald Duck
Engineer
Engineer
Posts: 11
Joined: 24 Apr 2020 07:05

Split the "Warn if vehicle is lost" setting by vehicle type

Post by Donald Duck »

Because of this bug, I've been forced to turn off the "Warn if vehicle is lost" setting, because otherwise I keep getting a bunch of incorrect messages saying that "Ship X is lost" when it's not. However, the problem with turning off that setting completely is that now I don't get warned if my trains are lost or stuck.

So I have two options: Either I turn the setting on and get incorrect "Ship X is lost" messages every few minutes, or I turn the setting off and I won't get warned if my trains are lost or stuck, which can easily happen for example if I place a signal wrong or if I forget to electrify one tile.

Obviously the best way to fix this is to fix the bug I linked to, but if that's to difficult I have a suggestion for how to at least make that bug less serious. I suggest splitting up the "Warn if vehicle is lost" setting into 5 different settings:
  • Warn if road vehicle is lost
  • Warn if train is lost
  • Warn if train is stuck
  • Warn if ship is lost
  • Warn if aircraft is lost
That way I can turn off the "Warn if ship is lost" setting to disable the false messages (ships rarely if ever actually get lost), while turning on the settings "Warn if train is lost" and "Warn if train is stuck".
Post Reply

Return to “OpenTTD Suggestions”

Who is online

Users browsing this forum: No registered users and 6 guests