cargodist glitches

Got a problem with OpenTTD? Find some help here.

Moderator: OpenTTD Developers

Post Reply
McZapkie
Tycoon
Tycoon
Posts: 1255
Joined: 18 Jan 2014 18:10

cargodist glitches

Post by McZapkie »

Seems that cargodist is generating links if there are any vehicles capable to transport such cargo, even if they are not refitted (and has no autorefit enabled).
I noticed it first when I added caboose to my set, which can carry goods or passengers. Freight train with such caboose was inducing lot of passengers waiting for not-existing tranport.
I removed passenger cargo from caboose to fix it, but now this bug strikes back - I'm playing with cargo dist enabled for freight and train with universal boxcars is inducing wrong links.
Is it known bug?
Projects: Reproducible Map Generation patch, NewGRFs: Manpower industries, PolTrams, Polroad, 600mm narrow gauge, preindustrial houses, wired, ECS industry extension, V4 CEE train set.
Addicted to freeciv longturn.
McZapkie
Tycoon
Tycoon
Posts: 1255
Joined: 18 Jan 2014 18:10

Re: cargodist glitches

Post by McZapkie »

More details: fake linkgraphs occurs, if given vehicle is autorefitted and has capability to transport cargodist cargo,
even if such cargo doesn't exists at any station used by this vehicle.

For example covered wagon, can be autorefitted to goods, grain, livestock and is used to transport latter two between farm and food factory - but white goods link will appear between these stations.
Projects: Reproducible Map Generation patch, NewGRFs: Manpower industries, PolTrams, Polroad, 600mm narrow gauge, preindustrial houses, wired, ECS industry extension, V4 CEE train set.
Addicted to freeciv longturn.
Post Reply

Return to “OpenTTD Problems”

Who is online

Users browsing this forum: No registered users and 7 guests