Trains get stuck after railtype change

Got a problem with OpenTTD? Find some help here.

Moderator: OpenTTD Developers

Post Reply
Hei
Engineer
Engineer
Posts: 3
Joined: 04 Jan 2019 21:18
Location: Joensuu

Trains get stuck after railtype change

Post by Hei »

Problem: Trains sometimes get totally stuck in front of the station after upgrading the railtype.

Have a look at this video and/or the attached savegame. The first railtype change did not break anything, but the second one did.


I have only seen this behaviour when using FRISS - Rail Infrastructure version 1.0.2, so I’m not sure whether this is a bug in OpenTTD itself or in that particular NewGRF.
Attachments
Kokkola Transport, 18.  7. 1982.sav
Trains don’t move any more.
(10.13 KiB) Downloaded 39 times

juzza1
Engineer
Engineer
Posts: 95
Joined: 22 Oct 2004 19:27

Re: Trains get stuck after railtype change

Post by juzza1 »

Tested your save, manually replacing the station frees the trains, but using the convert rail tool doesn't. In both cases the railtype returned by the land area information tool is the same. Railtypes can't define any special functionality for manual replacement vs convert rail, so I don't see how this could be an issue with the NewGRF. Friss Rails uses the newish NewGRF feature of 16+ railtypes, so this could be some lingering bug regarding that feature, though this is pure conjencture.

Post Reply

Return to “OpenTTD Problems”

Who is online

Users browsing this forum: No registered users and 4 guests