Compile OpenTTD 1.9.2 on Ubuntu 19.04

Got a problem with OpenTTD? Find some help here.

Moderator: OpenTTD Developers

Post Reply
ForKicks
Engineer
Engineer
Posts: 2
Joined: 04 Aug 2019 10:25

Compile OpenTTD 1.9.2 on Ubuntu 19.04

Post by ForKicks » 04 Aug 2019 13:30

Hi!

Trying to compile the OpenTTD 1.9.2 from source, but I'm stuck on make.

I'm reciving: OpenTTD-1.9.2/src/language.h:17:10: fatal error: unicode/coll.h: No such file or directory

I'm almost certain I have the correct libraries, but I guess not.

Anyone know what I'm missing?

User avatar
jfs
Director
Director
Posts: 544
Joined: 08 Jan 2003 23:09
Location: Denmark

Re: Compile OpenTTD 1.9.2 on Ubuntu 19.04

Post by jfs » 04 Aug 2019 13:32

The unicode/ includes are from ICU, so check if you have the right -dev packages for the right version of ICU installed.

ForKicks
Engineer
Engineer
Posts: 2
Joined: 04 Aug 2019 10:25

Re: Compile OpenTTD 1.9.2 on Ubuntu 19.04

Post by ForKicks » 04 Aug 2019 13:35

I have libicu-dev/disco,now 63.1-6 amd64 installed.

Couldnt find any information on version anywhere

Alberth
OpenTTD Developer
OpenTTD Developer
Posts: 4734
Joined: 09 Sep 2007 05:03
Location: home

Re: Compile OpenTTD 1.9.2 on Ubuntu 19.04

Post by Alberth » 05 Aug 2019 16:09

What do you think does "63.1" mean?

Packages normally have a version number embedded in their name.
Being a OpenTTD developer does not mean I know what I am doing.
Also, other OpenTTD developers may have different opinions.

arikover
Route Supervisor
Route Supervisor
Posts: 393
Joined: 15 Jun 2007 09:27
Skype: madchimiste
Location: Berlin, Deutschland

Re: Compile OpenTTD 1.9.2 on Ubuntu 19.04

Post by arikover » 06 Aug 2019 07:34

I don't know what does not work for you, but here are the steps I followed on Ubuntu 18.04:

0. Add source code to sources.list
App "Software&Updates", Tab "Ubuntu Software": check box "Source Code"

1. Download build dependencies for openttd

Code: Select all

$ sudo apt-get build-dep openttd
2. Install "git" (if you don't have it yet)

Code: Select all

$ sudo apt-get install git
3. Install MIDI enabler (if you want to play music)

Code: Select all

$ sudo apt-get install timidity freepats
4. Download Source Code

Code: Select all

$ git clone https://github.com/OpenTTD/OpenTTD.git
5. Configure and compile

Code: Select all

$ ./configure
$ make
6. Launch the executable

Code: Select all

$ ./bin/openttd

vicctoraquino
Engineer
Engineer
Posts: 1
Joined: 12 Aug 2019 21:51

Re: Compile OpenTTD 1.9.2 on Ubuntu 19.04

Post by vicctoraquino » 13 Aug 2019 00:54

Thanks a lot for updating!
I tried this but unfortunately I get this message when downloading dependencies:

***
Reading package lists... Done
E: Unable to find a source package for openttd
***

I haven't played it in 4 years and I just wish I can come back :)

arikover
Route Supervisor
Route Supervisor
Posts: 393
Joined: 15 Jun 2007 09:27
Skype: madchimiste
Location: Berlin, Deutschland

Re: Compile OpenTTD 1.9.2 on Ubuntu 19.04

Post by arikover » 13 Aug 2019 19:24

It looks like you forgot the step 0: check the "source code" to the list of things downloadable from the internet.

This is how I did with Ubuntu 18.04:
  1. Open "Software & Updates"
  2. Tab "Ubuntu Software"
  3. Tick the "Source code" check box (you'll probably have to type a password)
This is also doable via the command line as explained here. It might be a bit different for Ubuntu 19.04, but I'm pretty sure there is a way to achieve this via the GUI.

Once you've achieved this, there should be no problem downloading the dependencies for OpenTTD (Step 1 in my previous post).

Post Reply

Return to “OpenTTD Problems”

Who is online

Users browsing this forum: No registered users and 4 guests