[Linux] MIDI music volume too loud? (slider doesn't work)

Got a problem with OpenTTD? Find some help here.

Moderator: OpenTTD Developers

Post Reply
User avatar
DesertBus
Engineer
Engineer
Posts: 17
Joined: 03 Jul 2018 03:33

[Linux] MIDI music volume too loud? (slider doesn't work)

Post by DesertBus » 31 May 2019 14:44

I'm playing the Linux port using Timidity/Pulseaudio for MIDI. The volume slider doesn't work, only for sound effects, the music is too overpowered. Do anyone know any tricks to manually make MIDI playback quieter? In Pulseaudio, I can turn down the volume for MIDI playback, but as soon as another track starts playing the volume gets back to 100%.
"Watch that s***, cowboy"

User avatar
jfs
Director
Director
Posts: 609
Joined: 08 Jan 2003 23:09
Location: Denmark

Re: [Linux] MIDI music volume too loud? (slider doesn't work)

Post by jfs » 31 May 2019 15:22

Problem is the Timidity support is via the "extmidi" code in OpenTTD, meaning it runs a new Timidity process every time a new track starts, which explains why the volume resets. It's also why the volume slider in-game doesn't work, there isn't any way to communicate volume changes to the external MIDI playback process.

My only suggestion would be to use the new(er) Fluidsynth-based MIDI output, which is included in the 1.9 branch. It runs in-process and fully supports volume control.

User avatar
DesertBus
Engineer
Engineer
Posts: 17
Joined: 03 Jul 2018 03:33

Re: [Linux] MIDI music volume too loud? (slider doesn't work)

Post by DesertBus » 01 Jun 2019 03:51

I searched Google for a looong time in the hope of finding a way to manually set the Timidity process to a default volume level, but no luck. I was hoping some Linux guru out there would appear here :lol: :lol: Tried the -V and -A command line switches (volume and amp) but nothing seems to change. Well, Fluidsynth is the way then. Thanks man :bow: :bow:
"Watch that s***, cowboy"

User avatar
DesertBus
Engineer
Engineer
Posts: 17
Joined: 03 Jul 2018 03:33

Re: [Linux] MIDI music volume too loud? (slider doesn't work)

Post by DesertBus » 24 Nov 2019 23:29

Over time I found a "trick", it's not very reliable but it is something. In conjunction with Pulseaudio (Xubuntu 16.04) I use the Pulseaudio-Equalizer app ("PulseAudio Equalizer - LADSPA plugin graphical user interface")
I set the EQ settings I want and press "Enable". Usually after that, if I set an app's volume within Pavucontrol, that volume level will be remembered over time. So if I change MIDI tracks, the volume I set before will be remembered.
If Pavucontrol does not remember the volume levels you set before, here is the trick: go back to the EQ program, disable it (uncheck the box) and Enable it back again. Usually this solves it. You have to set the volume levels on Pavucontrol once again after doing that.
Everytime you have Pavucontrol not remembering volume levels, repeat that process. Uncheck and re-check the box until it works (usually just doing once fixes it)
If you depend on the EQ app too much, one way to prevent having to do this all the time is never disabling the EQ, but instead go directly to the profiles and select a different profile (save the ones you use, and click Flat to simulate the app turned off)
In case anyone wonders how I listen to MIDIs on Linux, I just use Winamp on Wine, really convenient, read all formats and is lighter in memory use. Just make sure to go to "Preferences", Plug-Ins, "Output" and select Pulseaudio, in case the audio is not being played properly.
"Watch that s***, cowboy"

Post Reply

Return to “OpenTTD Problems”

Who is online

Users browsing this forum: No registered users and 2 guests