Page 1 of 1

Dedicated Server ignores config.cfg

Posted: 10 Mar 2019 08:48
by EadZ1
Good morning!

For 2 days I've been trying to change settings for my dedicated server. The settings are applied in the config.cfg, but not applied in the game. I couldn't find a solution either here in the forum or in the wiki. That's why I hope for your help.

At first I changed all settings as desired. When no change was made, I saved the config.cfg separately and reinstalled the server. Then I try to chang only single settings, for example, city names from English to German or the starting year. But the game is running with default settings.

What can this be?

Regards

Re: Dedicated Server ignores config.cfg

Posted: 10 Mar 2019 10:27
by jfs
Usually the config file is named openttd.cfg, if you named yours differently are you sure you're passing the right filename to the -c commandline parameter?

Re: Dedicated Server ignores config.cfg

Posted: 10 Mar 2019 10:44
by EadZ1
I didn't change the name if this file, so i think it isn't necessary to use the parameter.

Re: Dedicated Server ignores config.cfg

Posted: 10 Mar 2019 14:07
by jfs
Let's try again: If you want OpenTTD to find your config file without using commandline parameter, the name of the file must be "openttd.cfg".

Re: Dedicated Server ignores config.cfg

Posted: 10 Mar 2019 14:07
by planetmaker
Make sure to have your server NOT running when you change the config file; OpenTTD makes a save of the settings upon terminating and might overwrite the changes you made while it was running.

Or use the -c configfilename flag to load from a non-default file which will not be overwritten when OpenTTD terminates.

Re: Dedicated Server ignores config.cfg

Posted: 10 Mar 2019 15:47
by EadZ1
Oh, I'm sorry. The filename is openttd.cfg and not config.cfg as I wrote above.

I just reinstalled the server again und stopped it immediately. Then I copied the openttd.cfg I've saved before and restarted the server - it works! This I also tried the last 2 days. Don't know why it's running now.

Thanks for your help!