Transport Tycoon Forums

The place to talk about Transport Tycoon
It is currently Sat Apr 20, 2019 5:15 pm

All times are UTC




Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Thu Feb 07, 2019 9:42 am 
Offline
Engineer
Engineer

Joined: Thu Feb 07, 2019 9:32 am
Posts: 1
Hello,
We are having problem with launching new game from heightmap (created locally) as multiplayer game on server. My setup (current version of game 1.8):

1) i pick newgrfs I want to play, on my local PC. I copy all settings needed to CFG file on server (Linux Centos). I upload all TAR files to coresponding directories, everything looks the same.
2) i create a new game from heightmap (Central_and_West_USA-1.tar from ingame loader), done successfully. Start the game, go save.
3) i upload the save to the server, and go launch server "./openttd -D -g save/autosave/server.sav"
4) i get an error

Code:
dbg: [net] Loading game failed, so a new (random) game will be started!
dbg: [net] Generating map, please wait...
dbg: [net] Map generation percentage complete: 5
dbg: [net] Map generation percentage complete: 10
dbg: [net] Map generation percentage complete: 15
dbg: [net] Map generation percentage complete: 20
dbg: [net] Map generation percentage complete: 25
dbg: [net] Map generation percentage complete: 30
dbg: [net] Map generation percentage complete: 35
dbg: [net] Map generation percentage complete: 40
dbg: [net] Map generation percentage complete: 45
dbg: [net] Map generation percentage complete: 50
dbg: [net] Map generation percentage complete: 55
dbg: [net] Map generation percentage complete: 60
dbg: [net] Map generation percentage complete: 65
dbg: [net] Map generation percentage complete: 70
dbg: [net] Map generation percentage complete: 75
dbg: [net] Map generation percentage complete: 80
dbg: [net] Map generation percentage complete: 85
dbg: [net] Map generation percentage complete: 90
dbg: [net] Map generation percentage complete: 99
dbg: [net] Map generated, starting game


and the map is newly generated. This happens all the time, no matter what I tried with config, newgrfs and so on.

What am I doing wrong? Is there a way to generate the startmap from heightmap locally and send it to server to act as basic stone for any new games launched there? Can I somehow debug, what is going wrong with the save game? (i am aware of -d param, but its more about debugging grfs, doesn't say anything usefull about savegame itself, afaik)

Thank you!


Top
   
PostPosted: Thu Feb 07, 2019 10:08 am 
Offline
OpenTTD Developer
OpenTTD Developer
User avatar

Joined: Wed Nov 07, 2007 10:44 pm
Posts: 9260
Location: Sol d
Loading the game will fail, if you miss any of the necessary NewGRFs (in the very exact version as required by the savegame). Maybe the server doesn't find the tars you uploaded (wrong dir?). Or if you miss the compression library needed to decompress the particular savegame (which might happen if you compiled OpenTTD from source yourself).

You can debug the found grfs by starting OpenTTD with "./openttd -D grf=X" where X is a number 0...9 (the bigger the more it will tell. It will tell you in particular which files are found where upon startup).

_________________
Image
OpenTTD: manual | online content | translations | Wanted contributions and patches
#openttdcoop: blog | wiki | public server | DevZone | NewGRF web translator
DevZone - home of the free NewGRFs: OpenSFX | OpenMSX | OpenGFX | Swedish Rails | OpenGFX+ Trains|RV|Industries|Airports|Landscape | NML


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000-2019 phpBB Limited

Copyright © Owen Rudge/The Transport Tycoon Forums 2001-2019.
Hosted by Zernebok Hosting.