Server game - error loading save

Got a problem with OpenTTD? Find some help here.

Moderator: OpenTTD Developers

Post Reply
Palalet
Engineer
Engineer
Posts: 1
Joined: 07 Feb 2019 09:32

Server game - error loading save

Post by Palalet » 07 Feb 2019 09:42

Hello,
We are having problem with launching new game from heightmap (created locally) as multiplayer game on server. My setup (current version of game 1.8):

1) i pick newgrfs I want to play, on my local PC. I copy all settings needed to CFG file on server (Linux Centos). I upload all TAR files to coresponding directories, everything looks the same.
2) i create a new game from heightmap (Central_and_West_USA-1.tar from ingame loader), done successfully. Start the game, go save.
3) i upload the save to the server, and go launch server "./openttd -D -g save/autosave/server.sav"
4) i get an error

Code: Select all

dbg: [net] Loading game failed, so a new (random) game will be started!
dbg: [net] Generating map, please wait...
dbg: [net] Map generation percentage complete: 5
dbg: [net] Map generation percentage complete: 10
dbg: [net] Map generation percentage complete: 15
dbg: [net] Map generation percentage complete: 20
dbg: [net] Map generation percentage complete: 25
dbg: [net] Map generation percentage complete: 30
dbg: [net] Map generation percentage complete: 35
dbg: [net] Map generation percentage complete: 40
dbg: [net] Map generation percentage complete: 45
dbg: [net] Map generation percentage complete: 50
dbg: [net] Map generation percentage complete: 55
dbg: [net] Map generation percentage complete: 60
dbg: [net] Map generation percentage complete: 65
dbg: [net] Map generation percentage complete: 70
dbg: [net] Map generation percentage complete: 75
dbg: [net] Map generation percentage complete: 80
dbg: [net] Map generation percentage complete: 85
dbg: [net] Map generation percentage complete: 90
dbg: [net] Map generation percentage complete: 99
dbg: [net] Map generated, starting game
and the map is newly generated. This happens all the time, no matter what I tried with config, newgrfs and so on.

What am I doing wrong? Is there a way to generate the startmap from heightmap locally and send it to server to act as basic stone for any new games launched there? Can I somehow debug, what is going wrong with the save game? (i am aware of -d param, but its more about debugging grfs, doesn't say anything usefull about savegame itself, afaik)

Thank you!

User avatar
planetmaker
OpenTTD Developer
OpenTTD Developer
Posts: 9278
Joined: 07 Nov 2007 22:44
Location: Sol d

Re: Server game - error loading save

Post by planetmaker » 07 Feb 2019 10:08

Loading the game will fail, if you miss any of the necessary NewGRFs (in the very exact version as required by the savegame). Maybe the server doesn't find the tars you uploaded (wrong dir?). Or if you miss the compression library needed to decompress the particular savegame (which might happen if you compiled OpenTTD from source yourself).

You can debug the found grfs by starting OpenTTD with "./openttd -D grf=X" where X is a number 0...9 (the bigger the more it will tell. It will tell you in particular which files are found where upon startup).

Post Reply

Return to “OpenTTD Problems”

Who is online

Users browsing this forum: Google [Bot] and 5 guests