Page 1 of 1

Cant start game on tablet

Posted: 13 May 2018 23:05
Hey everyone, ive recently installed the game to play openttd (played A LOT about 2 years ago on my pc) on my android through Playstore.

The really sad thing about it, is that it freezes on SDL loading screen with this message :

"Failed connecting to ... z/download"

Ive tried inumerous things, downloads, etc but it wont solve it.

Uninstalled it and re-installed about 6 times, still freezes on the same message.

Any one with a tip for it to work? Would love it, im really sad that i cant even start the game :evil: ;(

Thanks, hope yall having fun :wink: :]

Re: Cant start game on tablet

Posted: 25 May 2018 06:42
by DerekCZ
My friend had a similar issue when his phone was freezing during the download for no apparent reason.
We fixed it by copying my OTTD data folder to his phone, so it would skip the download process.
However, before you try something like that, try doing the following
1) Go to your apps, locate 'Download Manager' and clear its cached data and force stop it if its running
2) Do the same with OpenTTD and the Play Store
3) Remember to only delete cached data and not 'local data' or anything similar

Re: Cant start game on tablet

Posted: 03 Jul 2018 14:41
by pelya servers are regularly broken. Latest release of OpenTTD does not use them anymore, you will have to install zBase or aBase from inside the game.