Transport Tycoon Forums

The place to talk about Transport Tycoon
It is currently Mon Dec 11, 2017 2:18 am

All times are UTC




Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sun Aug 27, 2017 1:53 pm 
Offline
Engineer
Engineer

Joined: Sun Aug 27, 2017 1:25 am
Posts: 2
On a new world, this does not seem to be an immediate issue, however, I have one save that I've verified is causing issues. The mouse when moving will sometimes skip a frame render, or partially render on the screen when the game is paused. As worlds get heavier and heavier, the issue can become more pronounced. This can be occasionally be noticed when the game is unpaused but the effect is much easier to ignore, as it may skip once every 9th frame, whereas paused it can skip 5 frames or more. When paused, you can lose track of the mouse because it's skipping draws where you might expect it to be. I noticed there was a note relating this issue regarding high rate polling mouses (G500, the exact one I was using) , but I've tried two different mice, a cheap one and this one, as well as laptop hardware. I tried the save on three different hardware configuration platforms:

Platform 1: Desktop.
AMD 8350X @ 4.9GHZ
Nvidia 680GTX 2 SLI (Verified single GPU/Non-SLI configuration, results in same issue)
16GB DDR3 2666

Platform 2: Desktop.
Intel i7 3770K @ 3.5GHZ
AMD Radeon 5850
8GB DDR3 2400

Platform 3: Laptop.
AMD A8-4500M 1.9GHZ APU
AMD APU/GPU.
6GB DDR4.
(Touchpad input used)

Notes:
The issue does not appear any worse, or better, across all platforms. It seems to take a few seconds for it to appear on load sometimes though.

Troubleshooting done so far:
Capture the issue with a desktop viewing software, such as bandicam.
Result: The mouse appears perfectly fine when reviewing.

Verified Vsync is not causing the issue:
VSync is not causing the issue, even when forced on or off.

Modify Nvidia/AMD control panel settings to get desired result:
After exhausting all the functions, none of the settings would reduce this issue.

If anyone can help me resolve this please let me know. I don't see any options to force render a hardware/OS cursor. Thank you for any assistance.


Attachments:
File comment: This is the save file that has the issue that is occurring for me.
Test Corp, Sep 15th, 1994.sav [539.54 KiB]
Downloaded 11 times
Top
   
PostPosted: Sun Aug 27, 2017 2:18 pm 
Offline
Engineer
Engineer

Joined: Sun Aug 27, 2017 1:25 am
Posts: 2
I have posted the image of a display of the issue that shows on external monitors.

It would be hard to show it where frames that it doesn't render with an image. I don't see a reason. If you can replicate it let me know. I suspect you should be able to.


Attachments:
File comment: Showing mouse partially rendered.
PartialRender.png [2.81 MiB]
Not downloaded yet
Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000-2017 phpBB Limited

Copyright © Owen Rudge/The Transport Tycoon Forums 2001-2017.
Hosted by Zernebok Hosting.