Cannot install Openttd in Ubuntu 9.10 Karmic Beta

Got a problem with OpenTTD? Find some help here.

Moderator: OpenTTD Developers

Post Reply
Arnau
Engineer
Engineer
Posts: 54
Joined: 20 Jul 2006 10:18

Cannot install Openttd in Ubuntu 9.10 Karmic Beta

Post by Arnau » 18 Oct 2009 15:11

Hello,

It seems that libicu38 has been removed from the repos in Ubuntu Karmic 9.10 using instead libicu40.
Because of that it seems that it is not possible to install Openttd because it depends on libicu38 (which cannot be found)

Anyone else with this problem?

petert
Tycoon
Tycoon
Posts: 3008
Joined: 02 Apr 2009 22:43
Location: Massachusetts, USA

Re: Cannot install Openttd in Ubuntu 9.10 Karmic Beta

Post by petert » 18 Oct 2009 15:16

First, try a Search? Then, find the topic answered not 3 hours ago.

User avatar
Gremnon
Tycoon
Tycoon
Posts: 1517
Joined: 16 Sep 2005 12:23
Skype: the_gremnon
Location: /home
Contact:

Re: Cannot install Openttd in Ubuntu 9.10 Karmic Beta

Post by Gremnon » 18 Oct 2009 15:28

Failing all else, if it's a missing package that exists in Jaunty (It does) but not in Karmic, add the Jaunty Main repository, and install it via that.
I don't guarantee it'll fix it, or that it'll work, and you should exercise caution in using a repository for a different version of Ubuntu than the one you're using, but it *might* help you.
Also, personally, I'd wait until Karmic is officially released on the 29th, and see if the package reappears then.

Arnau
Engineer
Engineer
Posts: 54
Joined: 20 Jul 2006 10:18

Re: Cannot install Openttd in Ubuntu 9.10 Karmic Beta

Post by Arnau » 18 Oct 2009 15:32

Petert, you are not helping at all with this kind of anwer. Please read my question first. I already searched and there is no topic related.
They talk about the compiling problems under windows (Microsoft compiler) and I'm talking about not being able to install Openttd under ubuntu linux because of dependency problems.

Thanks Gremmon, I could find the package from Jaunty repo! Now it works!
In case it doesn't appear in the future it is posible to link openttd to libicu40?

Rubidium
OpenTTD Developer
OpenTTD Developer
Posts: 3815
Joined: 09 Feb 2006 19:15

Re: Cannot install Openttd in Ubuntu 9.10 Karmic Beta

Post by Rubidium » 18 Oct 2009 17:02

Arnau wrote:In case it doesn't appear in the future it is posible to link openttd to libicu40?
Yes it is, but then it doesn't work in Debian Lenny anymore (which is what the package is build for/on). To make matters worse the next Debian release is going to have a libicu newer than 4.0.

User avatar
Gremnon
Tycoon
Tycoon
Posts: 1517
Joined: 16 Sep 2005 12:23
Skype: the_gremnon
Location: /home
Contact:

Re: Cannot install Openttd in Ubuntu 9.10 Karmic Beta

Post by Gremnon » 18 Oct 2009 17:38

Oh, the joys of Debian, Ubuntu and systems based on them.
I think for now, this will have to do as a workaround - or Debian users will have to hope the old version of the library is still available in the repositories, force it to this version, and hope nothing requires the newer version.

Arnau
Engineer
Engineer
Posts: 54
Joined: 20 Jul 2006 10:18

Re: Cannot install Openttd in Ubuntu 9.10 Karmic Beta

Post by Arnau » 21 Oct 2009 11:17

In order to avoid the risks of adding old repos on new ubuntu 9.10, I just left the links to the needed package of libicu38 to run Openttd on Ubuntu 9.10:

For 32bit K/Ubuntu 9.10
http://launchpadlibrarian.net/33315218/ ... 1_i386.deb

For 64bit K/Ubuntu 9.10
http://launchpadlibrarian.net/33315202/ ... _amd64.deb

Just installing this package openttd works again!

Hope it helps
Last edited by Arnau on 28 Dec 2009 13:32, edited 1 time in total.

lollus
Engineer
Engineer
Posts: 20
Joined: 06 Oct 2004 09:42

Re: Cannot install Openttd in Ubuntu 9.10 Karmic Beta

Post by lollus » 19 Nov 2009 23:33

Thanks mate, you are a star.

I am running Kubuntu 6.10 and I was so frustrated it could not manage TTD. Now I stop playing around with Linux and breaking things and rather break things in TTD. Thanks again.

PTOPedro
Engineer
Engineer
Posts: 2
Joined: 21 Dec 2009 06:09

Re: Cannot install Openttd in Ubuntu 9.10 Karmic Beta

Post by PTOPedro » 21 Dec 2009 06:20

I'm having a problem playing it.....it doesn't pop up. i did install the libicu38, but nothing has changed it. Every time i install the game it pops up saying "For it's operation, OpenTTD needs the data files from the original Transport Tycoon Deluxe Game. See the /usr/share/doc/openttd/README.Debian for more details about the needed files and their location." I looked it up and it gave me the files names...but they don't tell me where to get them....can anyone help me find them? So sad right now that i can't play it. ;(

Rubidium
OpenTTD Developer
OpenTTD Developer
Posts: 3815
Joined: 09 Feb 2006 19:15

Re: Cannot install Openttd in Ubuntu 9.10 Karmic Beta

Post by Rubidium » 21 Dec 2009 07:34

As the message says: from the original Transport Tycoon Deluxe.

User avatar
planetmaker
OpenTTD Developer
OpenTTD Developer
Posts: 9293
Joined: 07 Nov 2007 22:44
Location: Sol d

Re: Cannot install Openttd in Ubuntu 9.10 Karmic Beta

Post by planetmaker » 21 Dec 2009 10:38

Alternatively you may get OpenGFX. Read the OpenGFX readme how to solve the sample.cat error which will be next.

PTOPedro
Engineer
Engineer
Posts: 2
Joined: 21 Dec 2009 06:09

Re: Cannot install Openttd in Ubuntu 9.10 Karmic Beta

Post by PTOPedro » 21 Dec 2009 17:28

it works now! yays! Thanks you guys! Had to override my permissions in order to implement the files, but it works now.

Timmaexx
Transport Coordinator
Transport Coordinator
Posts: 301
Joined: 03 Jan 2009 17:55

Re: Cannot install Openttd in Ubuntu 9.10 Karmic Beta

Post by Timmaexx » 18 Feb 2010 13:48

Hello,

downloaded OpenTTD 1.0.0 RC1, while running GDebi it tell me it cannot install cause there's a newer Version of the program aviable! What do I have to do?

MfG Tim

Eddi
Tycoon
Tycoon
Posts: 7414
Joined: 17 Jan 2007 00:14

Re: Cannot install Openttd in Ubuntu 9.10 Karmic Beta

Post by Eddi » 18 Feb 2010 19:41

some package managers get confused with "RC" and "beta" in the version numbers, in that case, there should be some kind of "--force" option to override these checks
You might not exactly be interested in Ferion, but if you are, have fun :)

Timmaexx
Transport Coordinator
Transport Coordinator
Posts: 301
Joined: 03 Jan 2009 17:55

Re: Cannot install Openttd in Ubuntu 9.10 Karmic Beta

Post by Timmaexx » 18 Feb 2010 21:43

Yeah thought about this!
Terminal gave me error:

Code: Select all

tim@tim-pc:~$ sudo dpkg --force /home/tim/Downloads/openttd-1.0.0-RC1-linux-debian-lenny-i386.deb
dpkg: unbekannte force/refuse-Option »/home/tim/Downloads/openttd-1.0.0-RC1-linux-debian-lenny-i386.deb«

Eddi
Tycoon
Tycoon
Posts: 7414
Joined: 17 Jan 2007 00:14

Re: Cannot install Openttd in Ubuntu 9.10 Karmic Beta

Post by Eddi » 18 Feb 2010 22:13

that looks like it tries to interpret "/path/blah.deb" as parameter to --force, the --help or man page should give you more information on how to handle that.

unfortunately, i have only ever used rpm based distributions, so i can't help there.

my guess would be "dpkg --force <something that says 'ignore version'> /path/blah.deb"
You might not exactly be interested in Ferion, but if you are, have fun :)

Post Reply

Return to “OpenTTD Problems”

Who is online

Users browsing this forum: Google [Bot], jfs and 2 guests