Strange Speed Behavior

OpenTTD is a fully open-sourced reimplementation of TTD, written in C++, boasting improved gameplay and many new features.

Moderator: OpenTTD Developers

Post Reply
School
Engineer
Engineer
Posts: 56
Joined: 18 Apr 2004 09:30

Strange Speed Behavior

Post by School » 11 May 2004 07:44

Load the attached save game.

There are three trains, Train 1 and 3 is on the strange behavior.

First, click train three, see it move from north to south and south to north.
You would see that the speed is totally different. For south to north the train would fastly speed up to 400miles/h but suddenly decreace its speed exiting the tunnel.
For north to south the train failed to get 400m/h, which is the maximum speed for that car.
If you rebuild the middle long tunnel by cutting it to two, you would also see that the speed of the car starts decreasing when it first leaves the tunnel from south to north.
NOTE: turn of the vehicle_speed switch to see the speed of the car and realistic_acceleration switch to see the strange bug.
Attachments
Strange Game.sav
The problemed save game.
(80.36 KiB) Downloaded 114 times

sbyrn9
Engineer
Engineer
Posts: 3
Joined: 03 Jan 2004 08:13
Location: Brisbane, Australia

Post by sbyrn9 » 11 May 2004 07:57

That behaviour is because when the train goes onto the bridge at 400m/h it must slow down to the top speed for the bridge which is 380m/h.

School
Engineer
Engineer
Posts: 56
Joined: 18 Apr 2004 09:30

Post by School » 11 May 2004 11:08

But the case it that in decreases even when the speed is below 380m/h.
It doesn't make sense.
Also the design of south to north and north to south is identical, the behavior should be also identical.

Post Reply

Return to “General OpenTTD”

Who is online

Users browsing this forum: No registered users and 7 guests