Page 1 of 1

TG Gold Ed. main menu issue

Posted: 24 Feb 2013 13:08
by peanutpope
Hi guys,

I'm new to this forum, been playing Transport Giant and now the Gold Edition. Also recently switched to Win8.

Native res for win: 1920x1080, which I also entered in the TG config file.

The issue: the main menu is only partly visible, lets say from the upper left corner to about 2/3 of the menu buttons. This makes it impossible to select anything properly.

Does anyone have this same issue and/or a solution to it?

Thank you very much!

(Sample of issue added)

Re: TG Gold Ed. main menu issue

Posted: 04 Mar 2013 20:56
by vince0018

I had another issue myself I was going to post about; many buildings in the 1950's being red, but I see from your screenshot you have this same issue.
I might be able to help you with your issue, but also wanted to see if anyone had a solution to the issue where buildings in the 50's are red.
I've tried changing many graphics settings in game and in my GFX Graphics Control Panel, but no fix yet.

Anyways I might be able to help you, we'll see.

One thing that I found I need to do when changing resolutions is to set the config to read only. That seems to be the only way it holds it's resolution.
I see you've tried editing the tg.ini file.

What I would do is add this to the top of tg.ini

Then go into the config folder and edit the GameStatus.xml.
Change your resolution, etc in there accordingly.

<DisplaySettings ScreenHeight="1080"/>
<DisplaySettings ScreenWidth="1920"/>
<DisplaySettings ColorDepth="32"/>
<DisplaySettings VSync="1"/>
<DisplaySettings Refreshrate="60"/>
<DisplaySettings Gamma="0.8969072104"/>
<DisplaySettings SoundVolume="1."/>
<DisplaySettings MusicVolume="95"/>
<DisplaySettings Cursor="1"/>

After saving the GameStatus.xml (which you may need to save to desktop and copy over the old one if it doesn't let you save immediately)
Make it read-only.
See if that works or not and report back. And ask if you have any questions as well.


Re: TG Gold Ed. main menu issue

Posted: 24 Aug 2013 20:21
by onix
Hi vince0018,

I have the same issue where buildings in the 50's are red. Did you find the solution to this problem?.

I´m running Transport Giant Gold Edition in Windows 7, with an NVIDIA GeForce GT 520 graphic card.

I think thaht the red buildings means that the graphics are missing but i didn´t find the solution.

Re: TG Gold Ed. main menu issue

Posted: 21 Sep 2013 15:02
by j7n
The GOLD edition has at least one corrupted file (GFX.JFL), which leads to one town building being replaced with a red mask of another building. But since the corruption is spread throughout the big archive, I suspect that maybe another one or two objects are corrupted too.

Please try this patch, and report if it fixes the problem. The patch will not apply if your file is of a different version, so it's safe. ... gfxjfl.exe

The problem is definitely not caused by video card settings.

Screenshots: red building, fixed.

Re: TG Gold Ed. main menu issue

Posted: 22 Jun 2014 17:03
by tedo21
Could you please re-activate the link? I want to try the patch.

Re: TG Gold Ed. main menu issue

Posted: 23 Jun 2014 18:25
by j7n
Reuploaded. ... gfxjfl.exe

Screenshots: red building, fixed.

I ran a binary compare between files of the "gold" and "pre-gold" versions. If you have the exact copy of gold, the patch will turn it into the other version, which I hope fixes the problem. As you can see from the size of 6 KB, there is nothing extra attached to the exe.

Re: TG Gold Ed. main menu issue

Posted: 10 Jul 2014 22:09
by vince0018
Man, I completely forgot about posting in this forum.

I haven't played Transport Giant Gold in ages because of the Red Building issue.
I've been trying other games to fill that 'hole' but nothing quite cuts it.

Then I came across this post again and saw your fix.. I couldn't help but be more than a little excited, though still reserved since who knows if it would work.

So I used the patcher to patch the 'corrupt' file, went in-game and loaded a saved game that had the Red Buildings issue (that was a mistake hehe)
But the Red Buildings were still there.. However I quickly realized that it was because I was loading a previous save, and a new game needed to be created.

So I started a new game in the 1950's and spectated several of the cities. (Normally every city has at least a few red buildings)


I am so overjoyed right now you have no idea.. I can't wait to finish typing out this topic so I can go start a new game :D

I hope that in the future I won't have too much difficulty finding this forum again if I get a new PC or wipe my current PC (I have it bookmarked on this one) so that I can always use this fix.

Thank you so much j7n.. I don't know who you are or how you figured this out, but it's a life-saver.. you're so awesome, thank you!


Re: TG Gold Ed. main menu issue

Posted: 10 Jul 2014 22:41
by vince0018
Ok I spoke too soon :/

Loading an Endless Map in 1975, America, still has red buildings :(

Maybe there's more than one corrupt gfx file or something you missed?

Re: TG Gold Ed. main menu issue

Posted: 11 Jul 2014 06:34
by j7n
The buildings only appear within some date range, and not in the same places on a random map, which is why you might not have seen them at first. Old savegames should also be corrected, as only the graphic of affected objects changes.


Same save after "restoring" with the patch (going back to the broken version).


The difference between the two data files are single bits over a few a short ranges, suggesting some kind of a read error. Not sure how this would occur, as most disks would return nothing for a corrupted sector. I did compare other core files between the two game versions and didn't find any differences.

Checksums of GFX.JFL:
broken wrote:CRC32: F94C8FA9
MD5: 8A77EB0C807A5314462E238867AD3C30
good wrote:CRC32: 9022CFBD
MD5: C25311C737143C672D95BA8631E49C15
Please check the usual: That you have write access to the file. If the game has been installed into Program Files, Windows might be "protecting" it. In that case move the game elsewhere. Patcher should say "successful" in the end. The file date should change to reflect the update. Maybe this old patcher program doesn't run on the latest Windows. I don't know that. This is the only one I could find on short notice, and it's small and efficient, and works with large-ish files.

Re: TG Gold Ed. main menu issue

Posted: 11 Jul 2014 07:01
by vince0018

Ok, I got it fixed now.

I cut/pasted the whole TG:G folder from C:/Program Files(x86)/

Then when I used the 'Restore' setting on your patcher it said 'already patched' which was kinda strange for restoring.
So then I re-patched and got the 'crack successful' message:

Then I ran the game, making to to have it run as Administrator.

I then loading an Endless Game on a Normal Sized Map, 1975, USA. I checked every city on the map, no red buildings.
So I did this again, three more times; generating new maps and checking every city.. no red buildings.

That last time when I exited to the main menu I saw an all too familiar scene, one of the 'animated' backgrounds taking place in the 1960's where I always, always saw a red building in a particular spot.
The red building was gone, it was normal.

So I feel pretty confident now that it's fixed finally.

Hopefully it stays fixed hehe.

Now, now I can finally play, like I thought I could before ;)

Thank You Again, So Much,

Re: TG Gold Ed. main menu issue

Posted: 11 Jul 2014 07:23
by j7n
I think Windows keeps versions of files modified inside Program Files somewhere. You might have another 461 MB file for no reason. Maybe the problem can come back if the game is run again from within Program Files.

I'm glad it is solved for now. Beats downloading a file that large, I think.