Transport Tycoon Forums

The place to talk about Transport Tycoon
It is currently Mon Jun 26, 2017 10:24 pm

All times are UTC




Post new topic  Reply to topic  [ 28 posts ]  Go to page 1 2 Next
Author Message
 Post subject: Signature Image Issues
PostPosted: Sat Jan 07, 2017 4:41 am 
Offline
Tycoon
Tycoon
User avatar

Joined: Sat Jan 22, 2005 7:31 pm
Posts: 5894
Location: Wakefield, West Yorkshire
Possibly related to the SSL-ation of the forum a while back, but that thread is now locked.

My signature has reverted back to its bugged version back when the SSL stuff was introduced. I've checked the BBCode, and its still correctly set so the BBCode has not gone awry - however the signature image doesn't show (and i've checked, the image is still being produced correctly) If you go to the image link produced by the forum, it gives a 502 Bad Gateway.

I have noticed the same error appears in Emperor Jakes signature, noticed on the last post of the SSL thread here.

Has something been rolled back relating to the fix you did in the past Owen?

_________________
Image
Worst Behaved IRC Member of 2008, 2009 & 2010 - Go Me!


Last edited by Redirect Left on Sat Jan 07, 2017 10:44 pm, edited 1 time in total.

Top
   
PostPosted: Sat Jan 07, 2017 9:15 am 
Offline
Administrator
Administrator
User avatar

Joined: Fri Jan 26, 2001 8:18 pm
Posts: 23728
Skype: orudge
Location: Banchory, UK
Hmm, I think I had to manually replace the version of the camo image proxy being used - maybe it's been reverted. I'll need to check.

That said, your signature looks fine to me!

_________________
Owen Rudge
owenrudge.net | Owen's Transport Tycoon Station | Owen's Locomotion Depot | The Transport Tycoon Wiki


Top
   
PostPosted: Sat Jan 07, 2017 9:33 am 
Offline
Moderator
Moderator
User avatar

Joined: Sat Apr 02, 2005 7:01 am
Posts: 3651
Location: Sydney NSW Antipodea
I can't see the image in Redirect Left's signature. Running Google Chrome on Windows 10 (14986).

_________________
Formerly known as r0b0t_b0y2003, robotboy, roboboy and beclawat. The best place to get the most recent nightly builds of TTDPatch is: http://roboboy.users.tt-forums.net/TTDPatch/nightlies/


Top
   
PostPosted: Sat Jan 07, 2017 10:50 am 
Offline
Tycoon
Tycoon
User avatar

Joined: Tue Dec 03, 2002 10:36 am
Posts: 13156
Location: The Netherlands
Same for more signature images, including mine.

_________________
Image
Dutch Trainset for OpenTTD | Dutch Trainset Topic | Combined Roadset v0.10


Top
   
PostPosted: Sat Jan 07, 2017 2:12 pm 
Offline
Moderator
Moderator
User avatar

Joined: Sat Dec 18, 2004 5:35 pm
Posts: 14729
Location: Stockholm, Sweden
I can see my own signature photo, but not those of Redirect and Hyro.

_________________
Image
OpenTTD Scenarios:
Archipiélago Hermoso
(Latest Release: Version 3.2)
Turnpike Falls (Latest Release: Version 0.91) 2016-06-23


Top
   
PostPosted: Sat Jan 07, 2017 6:07 pm 
Offline
Tycoon
Tycoon
User avatar

Joined: Mon Apr 19, 2004 8:09 pm
Posts: 1731
Location: Sweden
I can see yours, but not mine.

/OK, now it's back again!

_________________
Image
Swedish trains * Swedish Town Names * BlockCAD * The GRFMaker Community Page


Last edited by AndersI on Sat Jan 07, 2017 9:30 pm, edited 1 time in total.

Top
   
PostPosted: Sat Jan 07, 2017 8:37 pm 
Offline
Administrator
Administrator
User avatar

Joined: Fri Jan 26, 2001 8:18 pm
Posts: 23728
Skype: orudge
Location: Banchory, UK
Images should be working again now; the SSL proxy was down it seems.

If you've got signature images hosted on TT-Forums, you can change the [img] tags to reference https://www.tt-forums.net/. Likewise, users.tt-forums.net is available over SSL too (https://users.tt-forums.net/whatever).

_________________
Owen Rudge
owenrudge.net | Owen's Transport Tycoon Station | Owen's Locomotion Depot | The Transport Tycoon Wiki


Top
   
PostPosted: Sat Jan 07, 2017 10:46 pm 
Offline
Tycoon
Tycoon
User avatar

Joined: Sat Jan 22, 2005 7:31 pm
Posts: 5894
Location: Wakefield, West Yorkshire
All working again now, at least for me.
Hopefully the SSL proxy will remain stable?

_________________
Image
Worst Behaved IRC Member of 2008, 2009 & 2010 - Go Me!


Top
   
PostPosted: Sat Jan 07, 2017 11:52 pm 
Offline
Administrator
Administrator
User avatar

Joined: Fri Jan 26, 2001 8:18 pm
Posts: 23728
Skype: orudge
Location: Banchory, UK
Hopefully; it was up for a few months quite happily. Not sure why it fell over. Sorry about that!

_________________
Owen Rudge
owenrudge.net | Owen's Transport Tycoon Station | Owen's Locomotion Depot | The Transport Tycoon Wiki


Top
   
PostPosted: Tue Feb 14, 2017 9:18 pm 
Offline
Tycoon
Tycoon
User avatar

Joined: Mon Apr 19, 2004 8:09 pm
Posts: 1731
Location: Sweden
It seems the problem is back? My signature is empty of pictures...

And I can't link to pictures in the post, either?

Image

_________________
Image
Swedish trains * Swedish Town Names * BlockCAD * The GRFMaker Community Page


Top
   
PostPosted: Tue Feb 14, 2017 9:31 pm 
Offline
Tycoon
Tycoon
User avatar

Joined: Wed Aug 04, 2010 3:48 pm
Posts: 7082
Location: Manchester
Indeed, seems to be back, I can't see Anders', Leftie's or Hyro's, but I can see Chrill's.

I'm using Chrome, I don't know if that makes a difference as to whether it would work or not.

_________________
POTM August 2012 Joint Winner
My Screenshot Thread

Image


Top
   
PostPosted: Tue Feb 14, 2017 9:35 pm 
Offline
Tycoon
Tycoon
User avatar

Joined: Sat Jan 22, 2005 7:31 pm
Posts: 5894
Location: Wakefield, West Yorkshire
Yup. It's been gone again for about 2-3 days that i have noticed.
Pilot wrote:
I'm using Chrome, I don't know if that makes a difference as to whether it would work or not.

I'm using Firefox, so i don't think so. Also same on my phone, which uses a mobile version of Chrome.

_________________
Image
Worst Behaved IRC Member of 2008, 2009 & 2010 - Go Me!


Top
   
PostPosted: Wed Feb 15, 2017 4:30 am 
Offline
Chairman
Chairman
User avatar

Joined: Tue Nov 23, 2010 9:25 pm
Posts: 892
Location: ::1
It's the issue with the SSL certificate for imageproxy.tt-forums.net - it expired on 12 Feb.


Top
   
PostPosted: Wed Feb 15, 2017 7:03 am 
Offline
Moderator
Moderator
User avatar

Joined: Sat Dec 18, 2004 5:35 pm
Posts: 14729
Location: Stockholm, Sweden
Yes, the problem has returned for me. Once more I can see my own signature but many others are missing.

_________________
Image
OpenTTD Scenarios:
Archipiélago Hermoso
(Latest Release: Version 3.2)
Turnpike Falls (Latest Release: Version 0.91) 2016-06-23


Top
   
PostPosted: Wed Feb 15, 2017 10:20 pm 
Offline
Administrator
Administrator
User avatar

Joined: Fri Jan 26, 2001 8:18 pm
Posts: 23728
Skype: orudge
Location: Banchory, UK
Blargh, I updated the SSL certificate for the main web server, but totally forgot about imageproxy. Sorry!

EDIT: Or rather, it seems nginx just hadn't been restarted...

_________________
Owen Rudge
owenrudge.net | Owen's Transport Tycoon Station | Owen's Locomotion Depot | The Transport Tycoon Wiki


Top
   
PostPosted: Wed Feb 15, 2017 10:34 pm 
Offline
Tycoon
Tycoon
User avatar

Joined: Sat Jan 22, 2005 7:31 pm
Posts: 5894
Location: Wakefield, West Yorkshire
Yup. It seems to all be functional again, cheers!

_________________
Image
Worst Behaved IRC Member of 2008, 2009 & 2010 - Go Me!


Top
   
PostPosted: Wed Apr 19, 2017 1:19 pm 
Offline
Tycoon
Tycoon
User avatar

Joined: Sat Jan 22, 2005 7:31 pm
Posts: 5894
Location: Wakefield, West Yorkshire
Having a new issue.

The proxy seems to be caching things, and not looking for an updated image. This has broken my signature. It's currently stuck at one from a while ago.

The latest version of the image is here; http://thefoxbox.xyz/last_train/out.php - however the signature has not updated and is currently displaying one from a while ago.

I've tried this on two computers, and one Raspberry Pi that had no previous contact with this forum to have any cached version of the signature. So i'm fairly sure its the actual proxy caching things and not displaying the new version.

_________________
Image
Worst Behaved IRC Member of 2008, 2009 & 2010 - Go Me!


Top
   
PostPosted: Fri Apr 21, 2017 9:15 am 
Offline
Administrator
Administrator
User avatar

Joined: Fri Jan 26, 2001 8:18 pm
Posts: 23728
Skype: orudge
Location: Banchory, UK
Yes, it is caching stuff now, to save bandwidth and to speed things up. It should respect HTTP cache-control headers though. It looks like your signature sends the following HTTP headers:

HTTP/1.1 200 OK
Date: Fri, 21 Apr 2017 09:14:11 GMT
Server: Apache/2.2.22 (Debian)
X-Powered-By: PHP/5.4.45-0+deb7u7
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: image/png

but doesn't include anything to say "don't cache me". Try sticking:

Header("Cache-Control: no-store, no-cache, must-revalidate, max-age=0");
Header("Cache-Control: post-check=0, pre-check=0", false);
Header("Pragma: no-cache");

into your PHP script, before you write anything else. That should tell the proxy not to cache it.

_________________
Owen Rudge
owenrudge.net | Owen's Transport Tycoon Station | Owen's Locomotion Depot | The Transport Tycoon Wiki


Top
   
PostPosted: Fri Apr 21, 2017 9:24 am 
Offline
Tycoon
Tycoon
User avatar

Joined: Wed Aug 04, 2010 3:48 pm
Posts: 7082
Location: Manchester
On an image side of things, is Chrill's Avatar not working for anyone else, or is he just trolling us all by changing it to the file not loading type thing?

_________________
POTM August 2012 Joint Winner
My Screenshot Thread

Image


Top
   
PostPosted: Fri Apr 21, 2017 9:35 am 
Offline
Administrator
Administrator
User avatar

Joined: Fri Jan 26, 2001 8:18 pm
Posts: 23728
Skype: orudge
Location: Banchory, UK
Chrill's image is working fine. :)

_________________
Owen Rudge
owenrudge.net | Owen's Transport Tycoon Station | Owen's Locomotion Depot | The Transport Tycoon Wiki


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 28 posts ]  Go to page 1 2 Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000-2017 phpBB Limited

Copyright © Owen Rudge/The Transport Tycoon Forums 2001-2017.
Hosted by Zernebok Hosting.