TT-Forums now only available over SSL

The latest news about the forums and the Transport Tycoon world is posted here.
Please also read the rules here before posting elsewhere in the forum.
User avatar
Redirect Left
Tycoon
Tycoon
Posts: 6578
Joined: 22 Jan 2005 19:31
Location: Wakefield, West Yorkshire

Re: TT-Forums now only available over SSL

Post by Redirect Left » 10 Jun 2016 20:31

Annoyingly, it's not producing any issues now. Using my home wifi or O2s network. Seems an intermittent (perhaps one off?) thing. Should it re-occur i'll see if there are any options for viewing certificate. Trying to go through settings and force it to use a certain data connection type, but so far its working on GRPS/3G/4G, can't seem to find anything to force it onto the EDGE network (based upon all the icons it display next to the clock)

In other news, are you any closer to zoning in on why it seems to disapprove of .php generated signatures / resolving it?
Image
Worst Behaved IRC Member of 2008, 2009 & 2010 - Go Me!

User avatar
orudge
Administrator
Administrator
Posts: 24026
Joined: 26 Jan 2001 20:18
Skype: orudge
Location: Banchory, UK
Contact:

Re: TT-Forums now only available over SSL

Post by orudge » 10 Jun 2016 22:17

I'm afraid not - not had a chance to look at it I'm afraid. I couldn't see any obvious cause for it though - don't think it was the .php extension, but rather some sort of weird corruption going on.

Timmaexx
Transport Coordinator
Transport Coordinator
Posts: 301
Joined: 03 Jan 2009 17:55

Re: TT-Forums now only available over SSL

Post by Timmaexx » 12 Jun 2016 22:17

Thank you very much for making the web and this forum a safer place! Haven't been here for a while (exactly more than a year) and I am happy to see this change. Hadn't expected this on this "old website". Launching Let'sEncrypt is a great step in the history of Internet.

User avatar
WWTBAM
Moderator
Moderator
Posts: 3682
Joined: 02 Apr 2005 07:01
Location: Sydney NSW Antipodea
Contact:

Re: TT-Forums now only available over SSL

Post by WWTBAM » 24 Aug 2016 02:13

Hey Owen, this post isn't displaying images or URL links to images correctly.
Formerly known as r0b0t_b0y2003, robotboy, roboboy and beclawat. The best place to get the most recent nightly builds of TTDPatch is: http://roboboy.users.tt-forums.net/TTDPatch/nightlies/

User avatar
Redirect Left
Tycoon
Tycoon
Posts: 6578
Joined: 22 Jan 2005 19:31
Location: Wakefield, West Yorkshire

Re: TT-Forums now only available over SSL

Post by Redirect Left » 24 Aug 2016 03:48

beclawat wrote:Hey Owen, this post isn't displaying images or URL links to images correctly.
Furthermore, my signature still doesn't appear to be displaying properly :(
Image
Worst Behaved IRC Member of 2008, 2009 & 2010 - Go Me!

User avatar
orudge
Administrator
Administrator
Posts: 24026
Joined: 26 Jan 2001 20:18
Skype: orudge
Location: Banchory, UK
Contact:

Re: TT-Forums now only available over SSL

Post by orudge » 24 Aug 2016 06:25

I know, I think the problem is a combination of lighttpd and the image proxy software. Need to try with nginx but haven't had time yet to do so.

User avatar
orudge
Administrator
Administrator
Posts: 24026
Joined: 26 Jan 2001 20:18
Skype: orudge
Location: Banchory, UK
Contact:

Re: TT-Forums now only available over SSL

Post by orudge » 24 Aug 2016 11:25

This will hopefully start working properly soon (depending on when your DNS updates).

User avatar
Redirect Left
Tycoon
Tycoon
Posts: 6578
Joined: 22 Jan 2005 19:31
Location: Wakefield, West Yorkshire

Re: TT-Forums now only available over SSL

Post by Redirect Left » 26 Aug 2016 18:59

Signature seems fixed. Many thanks - out of curiosity, what was it that was causing it to render incorrectly?

edit: It seems for some reason it is linking incorrectly, when it is converting to imageproxy url - should be http://thefoxbox.xyz/last_train/out.php?info but it appears to be omitting the ?info, at least when clicked, it brings up the page that'll appear on http://thefoxbox.xyz/last_train/out.php - without the ?info - Possibly an issue with the link rewriting?
Image
Worst Behaved IRC Member of 2008, 2009 & 2010 - Go Me!

User avatar
orudge
Administrator
Administrator
Posts: 24026
Joined: 26 Jan 2001 20:18
Skype: orudge
Location: Banchory, UK
Contact:

Re: TT-Forums now only available over SSL

Post by orudge » 26 Aug 2016 21:37

Hmm, I'll need to look into that - it should only be rewriting the img src.

User avatar
orudge
Administrator
Administrator
Posts: 24026
Joined: 26 Jan 2001 20:18
Skype: orudge
Location: Banchory, UK
Contact:

Re: TT-Forums now only available over SSL

Post by orudge » 29 Aug 2016 09:34

This should be fixed now - it's because it was linking to the image URL that it was getting confused (it was replacing both instances of the image URL with the proxied URL).

User avatar
Emperor Jake
Tycoon
Tycoon
Posts: 3063
Joined: 24 Apr 2007 09:37
Location: Straya

Re: TT-Forums now only available over SSL

Post by Emperor Jake » 02 Sep 2016 13:48

Hi, it seems there are still problems with this - anywhere that I've hotlinked to an image hosted elsewhere on the forums doesn't work anymore, this is especially apparent in the screenshot competition thread as well as my minor NewGRF thread. Is it just some server issues or are they gone permanently?

Strangely, only older posts seem to be affected, the more recent competiton post still works.
--Stuff I made (or helped make)--
ImageImageImageImage

--My Award-Winning Screenshots and Videos--

User avatar
orudge
Administrator
Administrator
Posts: 24026
Joined: 26 Jan 2001 20:18
Skype: orudge
Location: Banchory, UK
Contact:

Re: TT-Forums now only available over SSL

Post by orudge » 04 Sep 2016 08:24

Ah, they were images hosted locally on tt-forums.net (but using the [img] tag, and linking to http://), but a bug in the rewriting extension was causing problems for images hosted on tt-forums.net itself. Should be fixed now. :)

User avatar
Emperor Jake
Tycoon
Tycoon
Posts: 3063
Joined: 24 Apr 2007 09:37
Location: Straya

Re: TT-Forums now only available over SSL

Post by Emperor Jake » 05 Sep 2016 03:19

Excellent, thank you based admin :D
--Stuff I made (or helped make)--
ImageImageImageImage

--My Award-Winning Screenshots and Videos--

Locked

Return to “News”

Who is online

Users browsing this forum: No registered users and 2 guests