Transport Tycoon Forums

The place to talk about Transport Tycoon
It is currently Fri Apr 18, 2014 1:06 pm

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Doesn't compile
PostPosted: Mon Sep 13, 2004 2:21 pm 
Offline
Engineer
Engineer

Joined: Sun Sep 12, 2004 9:36 am
Posts: 75
Location: Germany
I installed the latest fltk ("emerge fltk") and also have pthreads support. When compiling (from archive "source.tgz"), I get the following errors:

chii GrafikEngine # make
make all-recursive
make[1]: Entering directory `/usr/src/zugspiel/GrafikEngine'
Making all in intl
make[2]: Entering directory `/usr/src/zugspiel/GrafikEngine/intl'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/usr/src/zugspiel/GrafikEngine/intl'
Making all in po
make[2]: Entering directory `/usr/src/zugspiel/GrafikEngine/po'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/usr/src/zugspiel/GrafikEngine/po'
Making all in include
make[2]: Entering directory `/usr/src/zugspiel/GrafikEngine/include'
make[2]: *** No rule to make target `GNODE.cc', needed by `all-am'. Stop.
make[2]: Leaving directory `/usr/src/zugspiel/GrafikEngine/include'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/zugspiel/GrafikEngine'
make: *** [all-recursive-am] Error 2

What do I do wrong?

_________________
Thanks to the cheaters, Multiplayer in ottd sucks.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Sep 25, 2004 5:31 pm 
Offline
Engineer
Engineer
User avatar

Joined: Wed May 05, 2004 7:36 pm
Posts: 42
Location: 3city
I get the same error. Does anybody know how to compile it?


Top
 Profile  
 
 Post subject: compiling
PostPosted: Wed Feb 15, 2006 5:37 pm 
Offline
Engineer
Engineer

Joined: Wed Feb 15, 2006 11:05 am
Posts: 26
hi there!
got it working here...
i moved everything from source to /home/chochmah/zugspiel/
and changed in file include/Makefile.am one varibale:
grafikengine_include_DATA = \
../src/GNODE.cc\
../src/GNODE.h
after that it compiled, but it could not find my fltk libs in the last step - the linking, so i copy & pasted it:
c++ -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wtraditional -Wpointer-arith -Wmissing-prototypes -O1 -g -o grafikengine main.o land.o 3ds.o RailNetworkClass.o Cam.o LandClass.o ZugClass.o ObjectClass.o TSNODE.o ONODE.o TextBubbelClass.o GNODE.o Init.o DepotNodeClass.o testwindow.o -L/usr/X11R6/lib -L/usr/local/qt/lib -L/usr/lib /usr/lib/libGLU.so /usr/lib/libGL.so -lXt -ldl -lpthread -lm /usr/lib/libglut.so -lSM -lICE -lXmu -lXext -lXi -lX11 -lfltk -lfltk_gl -lfltk_images

and add an
-L/usr/lib/fltk-1.1
your directory could be another .. !

=> it links and runs, sometimes :)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000-2013 phpBB Group

Copyright © Owen Rudge/The Transport Tycoon Forums 2001-2013.
Hosted by Zernebok Hosting.